HDU 1049 青蛙爬进 (水题_模拟)

Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
 

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
 

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
 

Sample Input
  
  
10 2 1 20 3 1 0 0 0
 

Sample Output
  
  
17 19
 


n为井深(m),u为上升的速度(m/s),d为下滑的速度 (m/s)



#include<iostream>
#include<cstdio> 
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
	int n,u,d,temp;
	int ans;
	while(cin>>n>>u>>d) {
		temp=0;
		ans=0;
		if(n==0 && u==0 && d==0) break;
		while(1){
			ans++;
			temp+=u;
			if(temp>=n) break;
			ans++;
			temp-=d;
		}
		cout<<ans<<endl;
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值