hdu 5929 Basic Data Structure(双端队列+模拟)

1 篇文章 0 订阅


Mr. Frog learned a basic data structure recently, which is called stack.There are some basic operations of stack:

PUSH x: put x on the top of the stack, x must be 0 or 1.
POP: throw the element which is on the top of the stack.

Since it is too simple for Mr. Frog, a famous mathematician who can prove "Five points coexist with a circle" easily, he comes up with some exciting operations:

REVERSE: Just reverse the stack, the bottom element becomes the top element of the stack, and the element just above the bottom element becomes the element just below the top elements... and so on.
QUERY: Print the value which is obtained with such way: Take the element from top to bottom, then do NAND operation one by one from left to right, i.e. If   atop,atop1,,a1 is corresponding to the element of the Stack from top to the bottom, value=atop nand atop1 nand ... nand a1 . Note that the Stack will not change after QUERY operation. Specially, if the Stack is empty now,you need to print ” Invalid.”(without quotes).

By the way, NAND is a basic binary operation:

0 nand 0 = 1
0 nand 1 = 1
1 nand 0 = 1

1 nand 1 = 0

Because Mr. Frog needs to do some tiny contributions now, you should help him finish this data structure: print the answer to each QUERY, or tell him that is invalid.
Input
The first line contains only one integer T ( T20 ), which indicates the number of test cases.

For each test case, the first line contains only one integers N ( 2N200000 ), indicating the number of operations.

In the following N lines, the i-th line contains one of these operations below:

PUSH x (x must be 0 or 1)
POP
REVERSE
QUERY

It is guaranteed that the current stack will not be empty while doing POP operation.
Output
For each test case, first output one line "Case #x:w, where x is the case number (starting from 1). Then several lines follow,  i-th line contains an integer indicating the answer to the i-th QUERY operation. Specially, if the i-th QUERY is invalid, just print " Invalid."(without quotes). (Please see the sample for more details.)
Sample Input
2
8
PUSH 1
QUERY
PUSH 0
REVERSE
QUERY
POP
POP
QUERY
3
PUSH 0
REVERSE
QUERY
Sample Output
Case #1:
1
1
Invalid.
Case #2:
0

        
  



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<deque>
using namespace std;
deque<int>deq;
char op[11];
int main()
{
    int T,n,num,i,j,top,bottom,flag;
    int cc=0;
    scanf("%d",&T);
    while(T--) {
        printf("Case #%d:\n",++cc);
        scanf("%d",&n);
        deq.clear();
        top=-1,bottom=0,flag=1;
        while(n--) {
            scanf("%s",op);
            if(strcmp(op,"PUSH")==0) {
                scanf("%d",&num);
                if(flag) {
                    if(num) ++top;
                    else deq.push_back(++top);
                }
                else {
                    if(num) --bottom;
                    else deq.push_front(--bottom);
                }
            }
            else if(strcmp(op,"POP")==0) {
                if(flag) {
                    top--;
                    if(!deq.empty() && deq.back()>top) deq.pop_back();
                }
                else {
                    bottom++;
                    if(!deq.empty() && deq.front()<bottom) deq.pop_front();
                }
            }
            else if(strcmp(op,"QUERY")==0) {
                if(flag) {
                    if(top<bottom) printf("Invalid.\n");
                    else if(deq.empty()) {
                        if((top-bottom+1)%2) printf("1\n");
                        else printf("0\n");
                    }
                    else {
                        if(deq.front()<top) {
                            if((deq.front()-bottom+1)%2) printf("1\n");
                            else printf("0\n");
                        }
                        else {
                            if((deq.front()-bottom)%2) printf("1\n");
                            else printf("0\n");
                        }
                    }
                }
                else {
                    if(top<bottom) printf("Invalid.\n");
                    else if(deq.empty()) {
                        if((top-bottom+1)%2) printf("1\n");
                        else printf("0\n");
                    }
                    else {
                        if(deq.back()>bottom) {
                            if((deq.back()-top+1)%2) printf("1\n");
                            else printf("0\n");
                        }
                        else {
                            if((deq.back()-top)%2) printf("1\n");
                            else printf("0\n");
                        }
                    }
                }
            }
            else flag = flag ^ 1;
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值