HDU - 5929 Basic Data Structure (deque)

Basic Data Structure

Time Limit: 7000/3500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3515    Accepted Submission(s): 733


Problem Description
Mr. Frog learned a basic data structure recently, which is called stack.There are some basic operations of stack:

 PUSH x: put x on the top of the stack, x must be 0 or 1.
 POP: throw the element which is on the top of the stack.

Since it is too simple for Mr. Frog, a famous mathematician who can prove "Five points coexist with a circle" easily, he comes up with some exciting operations:

REVERSE: Just reverse the stack, the bottom element becomes the top element of the stack, and the element just above the bottom element becomes the element just below the top elements... and so on.
QUERY: Print the value which is obtained with such way: Take the element from top to bottom, then do  NAND operation one by one from left to right, i.e. If   atop,atop1,,a1 is corresponding to the element of the Stack from top to the bottom,  value=atop nand  atop1 nand ... nand  a1. Note that the Stack  will notchange after QUERY operation. Specially, if the Stack is empty now,you need to print ” Invalid.”(without quotes).

By the way,  NAND is a basic binary operation:

 0 nand 0 = 1
 0 nand 1 = 1
 1 nand 0 = 1
 1 nand 1 = 0

Because Mr. Frog needs to do some tiny contributions now, you should help him finish this data structure: print the answer to each QUERY, or tell him that is invalid.
 

Input
The first line contains only one integer T ( T20), which indicates the number of test cases.

For each test case, the first line contains only one integers N ( 2N200000), indicating the number of operations.

In the following N lines, the i-th line contains one of these operations below:

 PUSH x (x  must be 0 or 1)
 POP
 REVERSE
 QUERY

It is guaranteed that the current stack will not be empty while doing POP operation.
 

Output
For each test case, first output one line "Case #x:w, where x is the case number (starting from 1). Then several lines follow,  i-th line contains an integer indicating the answer to the i-th QUERY operation. Specially, if the i-th QUERY is invalid, just print " Invalid."(without quotes). (Please see the sample for more details.)
 

Sample Input
 
 
2 8 PUSH 1 QUERY PUSH 0 REVERSE QUERY POP POP QUERY 3 PUSH 0 REVERSE QUERY
 

Sample Output
 
 
Case #1: 1 1 Invalid. Case #2: 0
Hint
In the first sample: during the first query, the stack contains only one element 1, so the answer is 1. then in the second query, the stack contains 0, l (from bottom to top), so the answer to the second is also 1. In the third query, there is no element in the stack, so you should output Invalid.
 

Source
 

Recommend
wange2014

题意:对一个栈有4种操作,PUSH x,把x放到栈顶,x只能是0或1,POP 弹出栈顶元素,REVERSE把栈内的元素变为逆序,QUERY为输出栈顶元素到最后一个元素与非值。

思路:PUSH和POP都很容易实现,REVERSE操作我们并不需要真的去实现,而是用一个flag变量记录它是否变为逆序,QUERY从栈顶到最后一个元素的与且值,与且运算虽然没有结合性,但是我们发现,无论前面是什么元素,只要最后一位元素为0,这些元素最后的与且值为1,这样的话我们可以记录距离栈顶最远的0的位置,如何去记录呢?我们用到了一个数据结构叫deque,双端队列,既可以在头进行删除添加元素,也可以在尾进行添加和删除元素,有一点需要特判,我们所记录的最远的0的位置前面没有任何元素,此时且或还是0。

#include <iostream>
#include <cstdio>
#include <deque>
#include <cstring>

using namespace std;

const int maxn = 450000;
int N = 200005;
int a[maxn],l,r,n,flag;
deque<int> dq;

void init(){
	l = N ;
	r = N - 1;
	while(dq.size()){
		dq.pop_front();
	}
	flag = 1;
}

void Push(int x){
	if(flag){
		a[++r] = x;
		if(x == 0){
			dq.push_back(r);
		}
	}
	else{
		a[--l] = x;
		if(x == 0){
			dq.push_front(l);
		}
	}
}
void Pop(){
	if(flag){
		if(a[r] == 0){
			dq.pop_back();
		}
		r--;
	}
	else{
		if(a[l] == 0){
			dq.pop_back();
		}
		l++;
	}
}
void Query(){
	if(dq.size() == 0){
		if(r < l){
			printf("Invalid.\n");
		}
		else{
			printf("%d\n",(r - l + 1) & 1);   
		}
		return;
	}
	if(flag){
		int mostl = dq.front();
		int num = mostl - l;
		if(num & 1){
			if(mostl == r){
				printf("1\n");
			}
			else{
				printf("0\n");
			}
		}
		else{
			if(mostl == r){
				printf("0\n");
			}
			else{
				printf("1\n");
			}
		}
	}
	else{
		int mostr = dq.back();
		int num = r - mostr;
		if(num & 1){
			if(mostr == l){
				printf("1\n");
			}
			else{
				printf("0\n");
			}
		}
		else{
			if(mostr == l){
				printf("0\n");
			}
			else{
				printf("1\n");
			}
		}
	}
}
int main(void){
	int t;
	int q;
	char op[15];
	scanf("%d",&t);
	int Case = 0;
	while(t--){
		printf("Case #%d:\n",++Case);
		init();
		scanf("%d",&q);
		while(q--){	
			scanf("%s",op);
			if(op[1] == 'O'){
				Pop();
			}
			else if(op[2] == 'S'){
				int temp;
				scanf("%d",&temp);
				Push(temp);
			}
			else if(op[0] == 'Q'){
				Query();
			}
			else{
				flag = !flag;
			}
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值