1028. 人口普查(20)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John
//通过一个类来记录所有人的信息,并且通过重载运算符来筛选和比较每一个人的年龄大小,最后输出

#include <iostream>
#include <sstream>
#include <string>
#include <set>

using namespace std;

class Person{
private:

	string birthday;
	int year, month, day;
public:
	string name;
	Person(){};
	Person(string n, string b) :name(n), birthday(b){
		getDays();
	};

	void getDays(){
		stringstream ss;
		int cnt = 0;
		for (int i = 0; i<birthday.size(); ++i){
			if (birthday[i] == '/'){
				if (cnt == 0){
					ss >> year;
				}
				else if (cnt == 1){
					ss >> month;
				}
				cnt++;
				ss.clear();
			}
			else{
				ss << birthday[i];
			}
		}
		ss >> day;
	}

	bool operator >=(const Person other)const{
		if (year == other.year){
			if (month == other.month){
				return day <= other.day;
			}
			else{
				return month <= other.month;
			}
		}
		else{
			return year <= other.year;
		}
	}


	bool operator <=(const Person other)const{
		if (year == other.year){
			if (month == other.month){
				return day >= other.day;
			}
			else{
				return month >= other.month;
			}
		}
		else{
			return year >= other.year;
		}
	}

};

int main(int argc, const char * argv[]) {

	const Person OLDEST("oldest", "1814/09/06");
	const Person YOUNGEST("yongest", "2014/09/06");

	Person young("oldest", "1814/09/06");
	Person old("yongest", "2014/09/06");


	int num, cnt = 0; cin >> num;
	string name, birthday;
	while (num--){
		cin >> name >> birthday;
		Person tmp(name, birthday);
		if (tmp >= YOUNGEST && tmp <= OLDEST){
			if (tmp >= old){
				old = tmp;
			}
			if (tmp <= young){
				young = tmp;
			}
			cnt++;
		}

	}
	if (cnt)
		cout << cnt << " " << old.name << " " << young.name;
	else
		cout << cnt;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值