Delta-wave

A triangle field is numbered with successive integers in the way shown on the picture below. 



The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length of the traveller's route. 

Write the program to determine the length of the shortest route connecting cells with numbers N and M. 

Input

Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).

Output

Output should contain the length of the shortest route.

Sample Input

6 12 

Sample Output

3

题解:gou'构建一个函数 zb

将 数字 所在 第几行第几个求出来;即(x,y);

然后将二维坐标(x,y)转化为三维坐标(用一个数组来表示),即可求出最短路线;

代码:

#include <iostream>
#include <cmath>
using namespace std;

void zb(int m,int a[])
{
    int i,x,y;
    for(i=0;;i++)
        if(i*i>=m){
           x=i;
           y=m-(i-1)*(i-1);
           break;
    }
    a[0]=(y-1)/2+1;
    a[1]=(i*i-m)/2+1;
    a[2]=x;
}
int main()
{
    int m,n;
    while(cin>>m>>n){
        int a[3],b[3];
        zb(m,a);
        zb(n,b);
        int sum=0;
        for(int i=0;i<3;i++){
            if(a[i]-b[i]>0) sum+=(a[i]-b[i]);
               else sum-=(a[i]-b[i]);
            }
        /*cout<<a[0]<<ends<<a[1]<<ends<<a[2]<<ends<<endl;
         cout<<b[0]<<ends<<b[1]<<ends<<b[2]<<ends<<endl;*/
         cout<<sum<<endl;
        }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值