New Year Bonus Grant

All programmers of Mocrosoft software company are organized in a strict subordination hierarchy. Every programmer has exactly one chief, except Bill Hates who is also the head of the company and has no chief.

Due to the celebration of the new 2003 year, chief accountant of Mocrosoft decided to pay a New Year Bonus Grant of 1000 dollars to some programmers. However being extremely concerned of the company wealth she would like to designate the least possible amount of money for these grants. On the other hand she didn��t want to be accused of being too greedy or of giving preferences to some programmers. To do this, she developed the following scheme of grants appointment:

 

  • Each programmer may either assign a grant to one of his subordinates or have a grant assigned to him by his chief or none of the above.

     

     

  • No programmer can simultaneously receive a grant and assign a grant to one of his subordinates.

     

     

  • No programmer can assign a grant to more than one of his subordinates.

     

The scheme seemed to be designed perfectly - nobody would like to assign a grant to anybody since in this case he himself would not receive money. But programmers somehow discovered the plan of chief accountant and decided to make a trick to get the most money possible and share them fairly afterwards. The idea was to make such grant assignments that the total amount of grant money received is maximum possible.

You were selected to write the program which will find the optimal grants appointment.

 

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Input

 

The first line of the input file contains integer N - the number of programmers in Mocrosoft company (2 <= N <= 500 000). Each programmer is assigned his unique identifier - integer number ranging from 1 to N. Bill Hates has number 1 and each programmer has the number greater then the number of his chief. The second line of the input file contains N - 1 integers, i-th of which being the number of the chief of the worker whose number is (i + 1).

 

Output

 

On the first line of the output file print the maximum possible amount of money workers can get. On the second line output the numbers of programmers that will receive grant in ascending order.

 

Sample Input

 

1

4
1 1 2

 

Sample Output

 

2000
3 4

题解:这道题就是一个树状图染色,根节点不染色,染色的节点的父节点和兄弟节点不能染色;

代码: 

#include <iostream>
#include <cstring>
using namespace std;

int main()
{
    int t,n,sum,i;
    int a[500050],b[500050];/*数组a储存是否分到钱(包括自己分到或者分给下级);数组b储存分到钱的员工编号*/
    while(cin>>t && t){
    while(t--){
        cin>>n;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        sum=0;
        a[1]=1;
        for(i=2;i<=n;i++)
            cin>>a[i];
        for(i=n;i>1;i--){
            if(a[i] && a[a[i]]){
            a[a[i]]=0;
            a[i]=0;
            b[sum]=i;
            sum++;
            }
        }
        cout<<sum*1000<<endl;
        for(i=sum-1;i>=0;i--){
            if(i==sum-1) cout<<b[i];
            else cout<<" "<<b[i];
        }
        cout<<endl;
        if(t) cout<<endl;
    }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值