Combinations

Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2

Take 1, 3

Take 1, 4

Take 2, 3

Take 2, 4

Take 3, 4

Input

Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output

For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input

3

4 2

5 0

6 4

Sample Output

Case 1: 6

Case 2: 1

Case 3: 15

题解:这题数据比较大,特别容易超时,所以仅靠费马小定理求逆元是不够的,故还要用 Lucas 定理;

代码:

#include <iostream>

using namespace std;

typedef long long LL;
const LL p=1000003;

LL fac[1000000+11] = {1,1};

void getfac()//打一个阶乘表
{
	for (int i = 2 ; i <= 1000000 ; i++)
		fac[i] = fac[i-1] * i % p;
}

LL pow_mod(LL a, LL n, LL p){
    LL ret = 1;
    LL tmp = a;
    while(n) {
        if(n & 1) ret = (ret * tmp) % p;
        tmp = tmp * tmp % p;
        n >>= 1;
    }
    return ret;
}// 快速幂;

LL inv(LL a, LL p) {
    return pow_mod(a, p-2, p);
}//费马小定理求乘法逆元;


LL C(LL n , LL k)
{
	if (k > n)
		return 0;
	else
		return fac[n] * (pow_mod(fac[k] * fac[n-k] % p, p - 2,p)) % p;
}

LL Lucas(LL n,LL k)		//Lucas定理递归
{
	if (k == 0)		//递归终止条件
		return 1;
	else
		return C(n % p , k % p) * Lucas(n / p , k / p) % p;
}

int main()
{
    getfac();
    int T;
    cin>>T;
    for(int kase=1; kase<=T; kase++)
    {
        LL n,k;
        cin>>n>>k;
        cout<<"Case "<<kase<<": "<<Lucas(n,k)<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值