MOOC 数据结构 09-排序2 Insert or Merge

题目详情

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6

思路和小结:

给出一个原始序列,和使用某种排序算法过程中的一个中间序列;要求通过中间序列来判断使用的是哪种排序算法,并给出该算法下的下一步序列;
在听老师解答前,我使用的是笨方法:即先插入排序走一遍,并每走一步就跟给出的中间序列对比,判断是否一样;插入排序走完了,都不是,那就归并排序走一遍;
方法虽然笨,但是好理解;
老师的解答就非常巧妙:先根据插入和归并的特性判断是哪一种,而且带出走到哪一步了,果然我还是太菜了;

自己写的笨方法代码

在这里插入图片描述

#include <stdio.h>
#include <stdbool.h>

bool Insertion_Sort( int A[],int B[],int N );

void Merge_Sort( int A[],int B[],int N );

void Merge_Pass( int A[],int TmpA[],int N,int Length );

void Merge( int A[],int TmpA[],int L,int R,int RightEnd );

bool Compare( int A[],int B[],int N );

void Print( int A[],int N );

int main()
{
	int N;
	scanf("%d",&N);
	
	int i,A[N],A1[N];
	for(i=0;i<N;i++){
		
		scanf("%d",&A[i]);
		A1[i] = A[i];
	}
	
	int B[N];
	for(i=0;i<N;i++){
		
		scanf("%d",&B[i]);
	}
	
	bool IsInsertionSort = Insertion_Sort( A,B,N );
	
	if(IsInsertionSort){
		
		printf("Insertion Sort\n");
		Print( A,N );
	}else{
		
		Merge_Sort( A1,B,N );
	}
	
	return 0;
}

bool Insertion_Sort( int A[],int B[],int N )
{
	int i,P,Temp;
	bool IsInsertionSort = false;
	
	for(P=1;P<N;P++){
		Temp = A[P];
		
		for(i=P;i>=1 && A[i-1]>Temp;i--){
			
			A[i] = A[i-1];
		}
		
		A[i] = Temp;
		
		if(IsInsertionSort){
			break;
		} 
		
		if(Compare( A,B,N )){
		
			IsInsertionSort = true;
		}
	}
 	
	return IsInsertionSort;
}

bool Compare( int A[],int B[],int N )
{
	int i;
	bool IsEqual = true;
	
	for(i=0;i<N;i++){
		
		if(A[i] != B[i]){
			IsEqual = false;
			break;
		}
	}
	
	return IsEqual;
}

void Merge_Sort( int A[],int B[],int N )
{
	int TmpA[N];
	int Length = 1;
	bool IsMergeSort = false;
	
	while(Length < N){
		
		Merge_Pass( A,TmpA,N,Length );
		Length *= 2;
		
		if(IsMergeSort){
			
			printf("Merge Sort\n");
			Print( TmpA,N );
			
			break;
		}
		
		if(Compare( TmpA,B,N )){
			IsMergeSort = true;
		}
		
		Merge_Pass( TmpA,A,N,Length );
		Length *= 2;
		
		if(IsMergeSort){
			
			printf("Merge Sort\n");
			Print( A,N );
			
			break;
		}
		
		if(Compare( A,B,N )){
			IsMergeSort = true;
		}
	}
}

void Merge_Pass( int A[],int TmpA[],int N,int Length )
{
	int i,j;
	for(i=0;i<=N-2*Length;i+=2*Length){
		
		Merge( A,TmpA,i,i+Length,i+2*Length-1 );
	}
	
	if(i+Length < N){
		Merge( A,TmpA,i,i+Length,N-1 );
	}else{
		for(int j=i;j<N;j++) TmpA[j] = A[j];
	}

}

void Merge( int A[],int TmpA[],int L,int R,int RightEnd )
{
	int LeftEnd = R-1;
	int Tmp = L;
	
	while(L <= LeftEnd && R <= RightEnd){
		
		if(A[L] <= A[R]){
			
			TmpA[Tmp++] = A[L++];
		}else{
			
			TmpA[Tmp++] = A[R++];
		}
	}
	
	while(L <= LeftEnd){
		
		TmpA[Tmp++] = A[L++];
	}
	
	while(R <= RightEnd){
		
		TmpA[Tmp++] = A[R++];
	}	
}

void Print( int A[],int N )
{
	int i;
	for(i=0;i<N-1;i++){
		
		printf("%d ",A[i]);
	}
	
	printf("%d",A[N-1]);
} 

根据老师的思路写的代码

#include <stdio.h>
#include <stdbool.h>
//待续
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值