09-排序2 Insert or Merge(插入和归并)

09-排序2 Insert or Merge (25分)

According to Wikipedia:
根据维基百科:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
插入排序迭代,每次重复消耗一个输入元素,并增加排序的输出列表。每次迭代插入排序都会从输入数据中删除一个元素,在排序列表中找到它所属的位置,然后将其插入。重复直到没有输入元素剩余为止。

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.
合并排序的工作方式如下:将未排序的列表划分为N个子列表,每个子列表包含1个元素(将1个元素的列表视为已排序)。然后重复合并两个相邻的子列表以产生新的排序子列表,直到仅剩1个子列表为止。

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
现在给定了整数的初始序列,再加上某种排序方法多次迭代的结果,您能否确定我们使用的是哪种排序方法?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
每个输入文件包含一个测试用例。对于每种情况,第一行给出一个正整数N(≤100)。然后在下一行中,将N个整数作为初始序列。最后一行包含N个数字的部分排序序列。假定目标序列总是递增的。一行中的所有数字都用空格分隔。

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
对于每个测试用例,请在第一行中“插入排序”或“合并排序”中打印以指示用于获取部分结果的方法。然后运行此方法再进行一次迭代,并在第二行中输出重新排序序列。保证答案对于每个测试用例都是唯一的。一行中的所有数字都必须用空格隔开,并且在行末必须没有多余的空格。

Sample Input 1:

10

3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6

解析

有点不真实了嗷,没有读懂题意。
第一行是正常的输入数组,第二行是一组排列的中间过程的数,需要判断使用的是插入排序还是归并排序。然后再做下一组顺序的输出。

代码

#include<bits/stdc++.h>
using namespace std;
#define Maxn 120
int main(){
	int n,a[Maxn],b[Maxn],length,count=0,i,flag=1;
	cin>>n;
	for(i=0;i<n;i++)
		cin>>a[i];
	for(i=0;i<n;i++)
		cin>>b[i];
	//从0到n遍历,如果数组b前面的是按顺序排列,
	//并且剩余的数与数组a对应相等,则为插入排序,否则是归并 
	for(i=0;i<n-1;i++){
		if(b[i]>b[i+1]){
			i++;
			break;
		}
	}
	count=i;
	for(i;i<n;i++){
		if(b[i]!=a[i]){
			break;
		}
	}
	
	if(i==n){
		cout<<"Insertion Sort"<<endl;
		sort(b,b+count+1);
	} else{
		cout<<"Merge Sort"<<endl;
		for(length=2;flag;length*=2){
			//在长度为length片段满足顺序排列的基础上判断length*2
			for(i=length;i<n;i+=length*2){
				if(b[i-1]>b[i]){
					flag=0;
					break;
				}
			}
		}
		for (i = 0;i + length <= n;i += length)
			sort(b + i, b + i + length);
		sort(b + i, b + n);
	}
	cout<<b[0];
	for(int j=1;j<n;j++){
		cout<<" "<<b[j];
	}
	return 0;
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值