PAT1007 Maximum Subsequence Sum

题目描述

Given a sequence of K integers { N1, N2, …, NK}. A continuous subsequence is defined to be { Ni, N​i+1 , …, Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目解析

这道题目并没有什么难点,10000的数据量如果暴力的话,会有最少10^8的时间复杂度,所以我们为了稳妥最好采用DP的解法,而这个状态转移方程就是
ans = max(ans+下一个,下一个),然后记录最大的最早的记录就ok了。

关键代码

for(int i=0;i<n;++i){
        int temp = sum;
        sum = max(sum+k[i],k[i]);
        if(temp+k[i]<=k[i]) x=i;
        if(sum>maxx){maxx=sum;maxp=i;minp=x;}
    }

全部代码

#include<iostream>
#include<cstdio>
using namespace std;
int k[10005]={0};
int main(){
    int n,x=0;
    bool ok = false;
    scanf("%d",&n);
    while(x<n) {scanf("%d",&k[x]);if(k[x++]>0) ok=true;}
    if(!ok) {
        printf("%d %d %d\n",0,k[0],k[n-1]);
        return 0;
    }
    int sum=0,maxx=-1,minp,maxp;
    for(int i=0;i<n;++i){
        int temp = sum;
        sum = max(sum+k[i],k[i]);
        if(temp+k[i]<=k[i]) x=i;
        if(sum>maxx){maxx=sum;maxp=i;minp=x;}
    }
    printf("%d %d %d\n",maxx,k[minp],k[maxp]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值