PAT A1007 Maximum Subsequence Sum

1007 Maximum Subsequence Sum

分数 25

作者 CHEN, Yue

单位 浙江大学

Given a sequence of K integers { N1​, N2​, ..., NK​ }. A continuous subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

两种方法,一种在线处理,即边输入边处理,另一种动态规划,但是得额外增加一个数组来记录使得当前数取得最大值的前驱位置。

在线处理:

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int INF = 1e9 ,maxn = 1e5;
int a[maxn];

int main()
{
    int n;
    cin >> n;
    for(int i=0; i<n; ++i)
        cin >> a[i];
    
    int maxsum = -INF,l = 0, r = n-1;
    int tempsum = 0,templ = 0,tempr = 0;
    
    for(int i=0;i<n;++i)
    {
        if(tempsum + a[i] < 0)
        {
            tempsum = 0;
            templ = i + 1;
        }
        else
        {
            tempsum += a[i];
            tempr = i;
        }
        
        if(tempsum > maxsum && templ <= tempr)
        {
            maxsum = tempsum;
            l = templ;
            r = tempr;
        }
            
    }
    
    if(maxsum < 0)
        maxsum = 0;
    cout << maxsum << ' ' << a[l] << ' ' << a[r] << endl;

    return 0;
}

动态规划:


#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn = 1e4+10;
int a[maxn], dp[maxn],pre[maxn];

int main()
{
    int n;
    cin >> n;
    
    for(int i=1;i<=n;++i)
    {
        cin >> a[i];
        pre[i] = i;
    }
    
    for(int i=1;i<=n;++i)
    {
        if(dp[i-1] + a[i] > a[i])
        {
            dp[i] = dp[i-1] + a[i];
            pre[i] = i-1;
        }
        else 
        {
            dp[i] = a[i];
            pre[i] = i;
        }
    }
        
        
    int l = 1, r= n, maxsum = -maxn*maxn;
    for(int i=1;i<=n;++i)
    {
        if(dp[i] > maxsum)
        {
            maxsum = dp[i];
            r = i;
        }
    }
    l = r;
    
    while(pre[l] != l)
        l = pre[l];
    
    if(maxsum < 0)
    {
        maxsum = 0;
        l = 1;
        r=  n;
    }
    
    cout << maxsum << ' ' << a[l] << ' ' << a[r] << endl;
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值