Fliptile 状态压缩搜索

状态压缩搜索:比如第一行有4个棋子,可以翻转,翻转的可能型就是都不翻,只翻第一个,只翻第二个,翻第一个和第二个,,,,很多种情况,每一种都有翻和不翻两种,也就是2的4次方 这样的话总不能去四重循环吧,压缩法就是可以把以上的状态简化为一重的循环,也就是0到15 就可以了

例题:
https://vjudge.net/problem/POJ-3279
Fliptile
Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input
Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

思路:
我下面代码写的思路是枚举的第一行,然后往下走,看哪一个需要修改
其实还可以每一行都枚举,也是用数字去枚举,也是可以过得

开始的错误代码:(找错误找了好久都没有找到):

import java.util.Scanner;

class Test48{
    static int m;
    static int n;
    static int h;
    static int [][] graph ;
    static int [][] vis ;
    static int res;
    static int ans;
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        m = sc.nextInt();
        n = sc.nextInt();
        res = m*n+1;
        ans = 0;
        graph = new int[m+1][n+1];
        vis = new int[m+1][n+1];
        for(int i =1;i<=m;i++){
            for(int j =1;j<=n;j++){
                graph[i][j] = sc.nextInt();
            }
        }

        double x = Math.pow(2,n);
        for(h=0;h<x;h++){
          dfs(h);
        }

        if(ans==res){
            System.out.println("IMPOSSIBLE");
        }else {
            for(int i =1;i<=m;i++){
                for(int j =1;j<=n;j++){
                    System.out.print(vis[i][j]+" ");
                }
                System.out.println();
            }
        }


    }

    static void dfs(int h){
        int ans = 0;
        for(int i=1;i<=n;i++){
            int g = h &1;
            if(g == 1){
                vis[1][i]=1;
                ans++;
            }
            h=h>>1;
        }
        for(int i=2;i<=m;i++){
            for(int j =1;j<=n;j++){
                if(is_black(i-1,j)){
                    vis[i][j] = 1;
                    ans++;
                }
            }
        }
        for(int i=1;i<=n;i++){
            if(is_black(m,i)){
                return;//直接返回到开始进入下一轮循环?
            }
        }

        if(ans<res){
            res = ans;
          //  return;
        }


    }

    static boolean is_black(int i,int j){
        int n = 0;
        int a[] ={-1,1,0,0};
        int b[] = {0,0,-1,1};
        if(graph[i][j]==1){
            for(int g= 0;g<4;g++){
                if((i+a[g])<0 || (i+a[g])> m  || (j+b[g])<0|| (j+b[g])>n) continue;
                if(vis[i+a[g]][j+b[g]]==1){
                    n++;
                }
            }
            if(n%2==0) return true;
            else return false;
        }

        if(graph[i][j]==0){
            for(int g= 0;g<4;g++){
                if((i+a[g])<0 || (i+a[g])> m  || (j+b[g])<0|| (j+b[g])>n) continue;
                if(vis[i+a[g]][j+b[g]]==1){
                    n++;
                }
            }
            if(n%2==0) return false;
            else return true;
        }
        return true;
    }
}

Ac 代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int N = 17;
const int dx[] = {-1, 0, 1, 0, 0};
const int dy[] = { 0,-1, 0, 1, 0};

int grid[N][N], state[N][N], tmp[N][N], rec[N][N];

int n, m, ans;
void flip(int x, int y) {
    tmp[x][y] = 1;
    int nx, ny;
    for(int i = 0; i < 5; i++) {
        nx = x+dx[i];
        ny = y+dy[i];
        state[nx][ny] = !state[nx][ny];
    }
}

bool isEmpty(int n) {
    for(int j = 1; j <= m; j++) {
        if(state[n][j])
            return false;
    }
    return true;
}

void solve(int st) {
    memcpy(state, grid, sizeof(grid));
    memset(tmp, 0, sizeof(tmp));

    int cnt = 0;
    for(int j = 0; j < m; j++) {
        if((st>>j) & 1) {
            flip(1, j+1);
            cnt++;
        }
    }

    for(int i = 2; i <= n; i++) {
        for(int j = 1; j <= m; j++) {
            if(state[i-1][j] == 1) {
                flip(i, j);
                cnt++;
            }
        }
    }

    if(isEmpty(n) && cnt < ans) {
        ans = cnt;
        memcpy(rec, tmp, sizeof(tmp));
    }
}

int main() {
    while(scanf("%d%d", &n, &m) != EOF) {
        for(int i = 1; i <= n; i++) {
            for(int j = 1; j <= m; j++) {
                scanf("%d", &grid[i][j]);
            }
        }

        ans = INF;
        int end = 1 << m;

        for(int st = 0; st < end; st++)
            solve(st);

        if(ans == INF)
            puts("IMPOSSIBLE");
        else {
            for(int i = 1; i <= n; i++) {
                printf("%d", rec[i][1]);
                for(int j = 2; j <= m; j++)
                    printf(" %d", rec[i][j]);
                puts("");
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值