洛谷1118 数字三角形

题目:

题目描述

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

    3   1   2   4
      4   3   6
        7   9
         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

有这么一个游戏:

写出一个1~N的排列a[i],然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少1,直到只剩下一个数字位置。下面是一个例子:

3 1 2 4

4 3 6

7 9 16 最后得到16这样一个数字。

现在想要倒着玩这样一个游戏,如果知道N,知道最后得到的数字的大小sum,请你求出最初序列a[i],为1~N的一个排列。若答案有多种可能,则输出字典序最小的那一个。

[color=red]管理员注:本题描述有误,这里字典序指的是1,2,3,4,5,6,7,8,9,10,11,12

而不是1,10,11,12,2,3,4,5,6,7,8,9[/color]

输入输出格式

输入格式:

两个正整数n,sum。

输出格式:

输出包括1行,为字典序最小的那个答案。

当无解的时候,请什么也不输出。(好奇葩啊)

输入输出样例

输入样例#1:
4 16
输出样例#1:
3 1 2 4

说明

对于40%的数据,n≤7;

对于80%的数据,n≤10;

对于100%的数据,n≤12,sum≤12345。

第一想法就是全排列找,发现超时,经过提醒发现数字排列位置不同,求和时加的个数不同,贡献的个数恰好是杨辉三角,然后就优化了

代码

#include<iostream>
#include<cstring>
using namespace std;
int vis[100],a[111],b[1001][1001],sum,n;
void dfs(int cur,int num)
{
    int i,j;
    
    if(cur>=n||num>=sum)
    {
    if(num==sum&&cur>=n)
    {
        for(j=1;j<=n;j++)
        cout<<a[j]<<" ";
        cout<<endl;
        exit(0);
    }
    return ;
    }
    for(i=1;i<=n;i++)
    {
    if(!vis[i])
    {
        a[cur+1]=i;
        vis[i]=1;
        dfs(cur+1,num+a[cur+1]*b[n][cur+1]);
        vis[i]=0;
    }
}
}
int main()
{
	int i,j;
    cin>>n>>sum;
    memset(b,0,sizeof(b));
    b[1][1]=1;
    for(i=2;i<=n;i++)
    for(j=1;j<=i;j++)
    b[i][j]=b[i-1][j-1]+b[i-1][j];
    memset(vis,0,sizeof(vis));
    dfs(0,0);
    return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值