hdu 1141 Factstone Benchmark

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1141

题目描述:

Factstone Benchmark

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1624    Accepted Submission(s): 918


Problem Description
Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.) 
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word. 

Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip? 

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating. 
 

Sample Input
  
  
1960 1981 0
 

Sample Output
  
  
3 8

题意:

求N!< 2 ^ bit 成立的 使N最大的值

题解:

两边取对数,然后化解 得出bit在一边的不等式。另外这种高精度数的程序很容易随随便便写错,在浮点数的与0比较(推荐减去0小于一个很小的数就行 不要==0),然后浮点数比较大小啊 这些 真实太容易得到WA了,写的时候尽量避免在浮点数有不确切性的操作,比如比较等等。

代码:

/*
N!<2^bit
log(N!)<log(2^bit)
log(1)+log(2)+......+log(N)<bit * log(2)
log(1)/log(2) + ......log(N)/log(2) < bit
*/
#include<stdio.h>
#include<iostream>
#include<string>
#include<stdlib.h>
#include<math.h>
using namespace std;
__int64 year=0,N=0;
__int64 bit=0;//wrong answer   compile error: __int64_t
double sum=0.0;
double logs[100]={0.0};
int main()
{
    while(scanf("%lld",&year)!=EOF&&year>0)
    {
        //bit=(int)pow(2.0,(year-1960)/10)*4;
        bit=(year-1960)/10+2;
        bit=1<<bit;
        N=1;
        sum=0;
        do
        {
//            if(logs[N]==0.0)
//            {
                sum+=log(N)/log(2.0);
//                logs[N]=sum;//logs[N]=log(1)/log(2)+......log(N)/log(2)
//            }
//            else
//            {
//                sum=logs[N];
//            }
            N++;
        }while(sum<bit);//wrong answer : sum < (double)bit
        printf("%lld\n",N-1-1);//-1 for N++  and another -1 is for sum > bit and let sum < bit so N-1 another
    }
    return(0);
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值