uva 10391 compound words

题目地址:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1332

题目描述:

You are to find all the two-word compound words in a dictionary. A two-word compound word is a
word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will
be no more than 120,000 words.

Output
Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input
a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output
alien
newborn

题意:

讲输入的i单词作为一个字典,然后找出由i字典的两个单词组成的符合词

题解:

考虑到复合词可能先于组成的单词出现,所以不能边输入边处理。
需要把所有的词输入,然后hash一遍。
然后再扫描一次输入序列的所有词,对每个词做分词 + hash查, 两个词都能在hash表找到的就是所要的复合词。

代码:

//
// Created by hp on 4/25/15.
//
#include "stdio.h"
#include "string.h"
#define MM 1000003
char sq [120005][20] = {'\0'};//begin with 1 while(u)
int head[MM] = {0}, next[MM] = {0}, sq_len = 0;
int get_hash(char ss[])
{
    int sum = 0, seed = 13, len = (int)strlen(ss);
    for(int i = 0; i <= len - 1; i++)
        sum = (sum * seed + ss[i]) % MM;
    return sum % MM;
}
void try_to_insert(int s)
{
    int h = get_hash(sq[s]);
    int u = head[h];
    while (u)
    {
        if(strcmp(sq[u], sq[s]) == 0) return;
        u = next[u];
    }
    next[s] = head[h];
    head[h] = s;
}
bool find_word(char ss[])
{
    int h = get_hash(ss);
    int u = head[h];
    while (u)
    {
        if(strcmp(sq[u], ss) == 0) return true;
        u = next[u];
    }
    return false;
}
bool is_compounds(int s)
{
    int len = (int)strlen(sq[s]);
    for(int i = 1; i <= len - 1; i++)//divide
    {
        char s1[20], s2[20];
        strcpy(s1, sq[s]);
        s1[i] = '\0';
        strcpy(s2, sq[s] + i);
        if(find_word(s1) && find_word(s2)) return true;
    }
    return false;
}
int main()
{
    while (scanf("%s", sq[++sq_len]) != EOF)
    {
        if(sq[sq_len][0] == '\0')
        {
            sq_len--;
            continue;
        }
        try_to_insert(sq_len);
    }
    for(int i = 1; i <= sq_len; i++)
    {
        if(is_compounds(i)) printf("%s\n", sq[i]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值