uva 539 The Settlers of Catan

题目地址:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=108&page=show_problem&problem=480


题目描述:

The Settlers of Catan 

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:


When the game ends, the player who built the longest road gains two extra victory points.


The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).


Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.


Example: The following network contains a road of length 12.

o        o -- o        o
 \      /      \      /
  o -- o        o -- o
 /      \      /      \
o        o -- o        o -- o
               \      /
                o -- o

Input 

The input file will contain one or more test cases.

The first line of each test case contains two integers: the number of nodes n ( $2 \le n \le 25$) and the number of edges m ( $1 \le m \le 25$). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.

Input will be terminated by two values of 0 for n and m.

Output 

For each test case, print the length of the longest road on a single line.

Sample Input 

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output 

2
12




题意:找存在的最长的欧拉回路。


题解:暴力深搜。


代码:

/*

topcoder codeforce acm

uva 10474 - Where is the Marble?

no repeat edges between two vertexs

*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<time.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;

typedef struct Points
{
	int start;
	int end;
	bool used;
	Points()
	{
		start=0;
		end=0;
		used=false;
	}
}Points,*PointsLink;
Points List[200+5];

bool Graph[25+5][25+5]={false};//true is connected

int n=0;//the count of the nodes,the node number begin with 0
int m=0;//the count of the edges
int MaxLen=0;

/*DFS the graph and find the euler path*/
int DFS(int cur,int Len)
{
	if(Len>MaxLen)
	{
		MaxLen=Len;
	}
	int i=0,j=0;
	for(i=0;i<=n-1;i++)
	{
		if(Graph[cur][i])//connected
		{
			//not used
			for(j=0;j<=m-1;j++)
			{
				if((cur==List[j].start&&i==List[j].end)||(cur==List[j].end&&i==List[j].start))
				{
					if(List[j].used==false)
					{
						List[j].used=true;
						DFS(i,Len+1);
						List[j].used=false;
						break;//has found so it is no need to continue to find
					}
				}
			}
		}
	}
	return(0);
}

/*for test*/
int test()
{
	return(0);
}

/*main process*/
int MainProc()
{
	while(scanf("%d%d",&n,&m)!=EOF&&(n>0||m>0))
	{
		int i=0;
		int Start=0,End=0;
		memset(Graph,false,sizeof(Graph));
		MaxLen=0;
		for(i=0;i<=m-1;i++)
		{
			scanf("%d%d",&Start,&End);
			Graph[Start][End]=true;
			Graph[End][Start]=true;
			List[i].start=Start;
			List[i].end=End;
			List[i].used=false;
		}
		if(m<=1)
		{
			printf("%d\n",m);
		}
		else
		{
			int Len=0;
			for(i=0;i<=n-1;i++)
			{
				Len=0;
				DFS(i,Len);
			}
			printf("%d\n",MaxLen);
		}
	}
	return(0);
}

int main()
{
	MainProc();
	return(0);
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值