Parenthesis CSU - 1809

1809: Parenthesis
Time Limit: 5 Sec Memory Limit: 128 Mb Submitted: 2226 Solved: 592
Description
Bobo has a balanced parenthesis sequence P=p1 p2…pn of length n and q questions.
The i-th question is whether P remains balanced after pai and pbi swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists balanced parenthesis sequence A,B such that S=AB;
3. or there exists balanced parenthesis sequence S' such that S=(S').
Input
The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤105,1≤q≤105).
The second line contains n characters p1 p2…pn.
The i-th of the last q lines contains 2 integers ai,bi (1≤ai,bi≤n,ai≠bi).

Output
For each question, output "Yes" if P remains balanced, or "No" otherwise.
Sample Input

4 2
(())
1 3
2 3
2 1
()
1 2

Sample Output

No
Yes
No

Hint
Source
湖南省第十二届大学生计算机程序设计竞赛

【题解】:




【代码】:

#include<cmath>
#include<cstdio>
#include<string>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    char s[200000];
    int sss[200000];
    int n,m;
    while(~scanf("%d %d",&n,&m)){
        memset(sss,0,sizeof(sss));
        scanf("%s",s);int flag=0;
        int sum=0;
        for(int i=0;i<n;i++){
            if(s[i]=='('){sum++;}
            else{sum--;}
            sss[i]=flag;
            if(sum<2){
                flag++;
               }
            
        }
        for(int i=0;i<m;i++){
            int a,b;
            scanf("%d %d",&a,&b);
            a=a-1;b=b-1;
            if(a>b){
                int t;t=a;a=b;b=t;
            }
            if(s[a]=='('&&s[b]==')'){
                if((sss[a]!=sss[b]))printf("No\n");
                else  printf("Yes\n");
            }
            else
                printf("Yes\n");
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值