hdu6153(kmp) A Secret

A Secret

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 256000/256000 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Today is the birthday of SF,so VS gives two strings S1,S2 to SF as a present,which have a big secret.SF is interested in this secret and ask VS how to get it.There are the things that VS tell:
  Suffix(S2,i) = S2[i...len].Ni is the times that Suffix(S2,i) occurs in S1 and Li is the length of Suffix(S2,i).Then the secret is the sum of the product of Ni and Li.
  Now SF wants you to help him find the secret.The answer may be very large, so the answer should mod 1000000007.
 

Input
Input contains multiple cases.
  The first line contains an integer T,the number of cases.Then following T cases.
  Each test case contains two lines.The first line contains a string S1.The second line contains a string S2.
  1<=T<=10.1<=|S1|,|S2|<=1e6.S1 and S2 only consist of lowercase ,uppercase letter.
 

Output
For each test case,output a single line containing a integer,the answer of test case.
  The answer may be very large, so the answer should mod 1e9+7.
 

Sample Input
  
  
2 aaaaa aa abababab aba
 

Sample Output
  
  
13 19
Hint
case 2: Suffix(S2,1) = "aba", Suffix(S2,2) = "ba", Suffix(S2,3) = "a". N1 = 3, N2 = 3, N3 = 4. L1 = 3, L2 = 2, L3 = 1. ans = (3*3+3*2+4*1)%1000000007. 【大佬】的题解,借大佬的题解补一下题目
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
#define ll long long
const int mn=1e6+5;
int n,m,nextval[mn];
char s[mn],t[mn];
ll id[mn];
const int mod=1e9+7;
void getNextval() {
    int i=0,j=-1;
    nextval[0]=-1;
    while(i<m) {
        if(j==-1||t[i]==t[j])
            nextval[++i]=++j;
        else j=nextval[j];
    }
}
void KMP() {
    int i=0,j=0;
    while(i<n) {
        if(j==-1||s[i]==t[j]) ++i,++j;
        else j=nextval[j];
        id[j]++;
        if(j==m)
        j=nextval[j];
    }
}
int main() {
    int T;
    scanf("%d",&T);
    while(T--) {
        memset(id,0,sizeof(id));
        scanf("%s%s",s,t);
        n=strlen(s),m=strlen(t);
        for(int i=0;i<=(n-1)/2;++i)
        swap(s[i],s[n-1-i]);
        for(int i=0;i<=(m-1)/2;++i)
        swap(t[i],t[m-1-i]);
        getNextval();
        KMP();
        ll ans=0;
        for(int i=m;i>0;--i)
        {
        	id[nextval[i]]+=id[i];
        	ans=(ans+id[i]*i)%mod;
		}
        printf("%lld\n",ans);
    }
    return 0;
}

【KMP的原样】:(我自己搜出来的,请指教啊)
#include <stack>
#include <vector>
#include <set>
#include <map>
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;
#define MAX_SIZE 100010
typedef char ElemType;
void CptPfFunc(ElemType Pattern[], int PrefixFunc[]);
void KMPstrMatching(ElemType Target[], ElemType Pattern[]);
char p[MAX_SIZE];
char t[MAX_SIZE];
int cnt;            ///记录匹配的的个数

int main()
{
    int re;

    scanf("%d",&re);
    while(re--){
        printf("please input string t:");
        cin>>t;
//        t.length=strlen(t.string);
        printf("please input string p:");
        cin>>p;
//        p.length=strlen(p.string);
//        getnext(p,next);
//        printf("\n%d\n",kmp(t,p,next));
        cnt=0;
        KMPstrMatching(t,p);
    }
    return 0;
}
/// Compute Prefix function
void CptPfFunc( ElemType Pattern[], int PrefixFunc[] )
{
    register int iLen = 0;    /// Length of Pattern[]
    while('\0'!=Pattern[iLen])
            iLen++;
    int LOLP=0;     /// Lenth of longest prefix
    PrefixFunc[1]=0;

    for(int NOCM=2;NOCM<iLen+1;NOCM++)     /// NOCM represent the number of characters matched
    {
            while(LOLP>0&&(Pattern[LOLP]!=Pattern[NOCM-1]))
                    LOLP=PrefixFunc[LOLP];
            if(Pattern[LOLP]==Pattern[NOCM-1])
                    LOLP++;
            PrefixFunc[NOCM]=LOLP;
    }
}

void KMPstrMatching(ElemType Target[],ElemType Pattern[])
{
    int PrefixFunc[MAX_SIZE];
    register int TarLen=0;
    register int PatLen=0;

    /// Compute the length of array Target and Pattern
    while('\0'!=Target[TarLen])
            TarLen++;

    while('\0'!=Pattern[PatLen])
            PatLen++;

    /// Compute the prefix function of Pattern
    CptPfFunc(Pattern,PrefixFunc);

    int NOCM=0;     /// Number of characters matched

    for(int i=0;i<TarLen;i++ )
    {
        while(NOCM>0&&Pattern[NOCM]!=Target[i])
                NOCM=PrefixFunc[NOCM];
        if(Pattern[NOCM]==Target[i])
                NOCM++;
        if(NOCM==PatLen )
        {
                cout<<"KMP String Matching,pattern occurs with shift "<<i-PatLen+1<<endl;
                cnt++;
                NOCM=PrefixFunc[NOCM];
        }
    }
    cout<<"cnt=: "<<cnt<<endl;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值