hdu1150——最小点覆盖

<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">hdu1150Machine Schedule:</span><a target=_blank href="http://acm.hdu.edu.cn/showproblem.php?pid=1150" style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">http://acm.hdu.edu.cn/showproblem.php?pid=1150</a>

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7288    Accepted Submission(s): 3640


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
  
  
3
题意:有k个任务需要有机器A、B完成,第i个任务可以由Am或Bm模型完成(A有n个模型,B有m个模型)。当完成任务所用的模型不同时需要换模型,花费时间为1 (当A机器的模型和B机器的模型都不符合时才需要重启机器更换模型,花费时间 1),问最小的花费时间是多少

思路:本题就是求最小点覆盖的,每个任务建立一条边,利用二分最大匹配求出最小点的覆盖。注意:在建边时需注意,每台机器开始都是处于模型0,所以当有一个模型为0时不需要建边(模型0不花费时间)。

补充:二分图的最小点覆盖数 = 最大匹配数 

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<string>
#include<stack>
using namespace std;

const int maxn=100 + 10;
int n,m,k;
int g[maxn][maxn];
int vis[maxn],link[maxn];

bool path(int u)
{
    for(int i = 0; i < m; i++)
    {
        if(g[u][i] && !vis[i])
        {
            vis[i] = 1;
            if(link[i] == -1 || path(link[i]))
            {
                link[i] = u;
                return true;
            }
        }
    }
    return false;
}

int dfs()
{
    int ans = 0;
    memset(link,-1,sizeof(link));
    for(int i = 0; i < n; i++)
    {
        memset(vis,0,sizeof(vis));
        if(path(i))ans++;
    }
    return ans;
}
int main()
{
//    freopen("in.txt","r",stdin);
    int t;
    while(~scanf("%d",&n) && n)
    {
        memset(g,0,sizeof(g));
        scanf("%d%d",&m,&k);
        int a,b,c;
        while(k --)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(!b || !c)continue;
            g[b][c] = 1;
        }
        int ans = dfs();
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值