Number Sequence

Number Sequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 45   Accepted Submission(s) : 14
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

Author

CHEN, Shunbao

Source

ZJCPC2004
#include<stdio.h>
int main()
{
    int a,b,n,i,t[1000],flag,m,num;
    while(scanf("%d%d%d",&a,&b,&n))
    {
        if(a==0&&b==0&&n==0) break;
       t[1]=1;t[2]=1;
       for(i=3;i<=200;i++)
       {
            t[i]=(a*t[i-1]+b*t[i-2])%7;
       }
       flag=1;
       for(i=3;i<=200&&flag==1;i++)
       {
           if(t[i]==1&&t[i+1]==1) flag=0;
           
       }
    
      
       m=i-2;
       num=n%m;
       if(num==0) printf("%d\n",t[m]);
       else
       printf("%d\n",t[num]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值