HDUOJ关于A+B的ti

//主要是训练输入输出的格式,以下八道题仅供参考。

A+B for Input-Output Practice (I)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 97643    Accepted Submission(s): 54096


Problem Description
Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.
 

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
 

Sample Input
  
  
1 5 10 20
 

Sample Output
  
  
6 30
 
#include<stdio.h>
int main(){
int a,b,c;
while(scanf("%d%d",&a,&b)!=EOF)
    { c=a+b;
 printf("%d\n",c);
    }
return 0;
}


A+B for Input-Output Practice (II)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 73531    Accepted Submission(s): 47796


Problem Description
Your task is to Calculate a + b.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
 

Sample Input
  
  
2 1 5 10 20
 

Sample Output
  
  
6 30

#include<stdio.h>
int main(){
int n;
scanf("%d",&n);
while(n--)
{ int a,b;
 scanf("%d%d",&a,&b);
 printf("%d\n",a+b);
}
return 0;
}



A+B for Input-Output Practice (III)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 84436    Accepted Submission(s): 44289


Problem Description
Your task is to Calculate a + b.
 

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
 

Sample Input
  
  
1 5 10 20 0 0
 

Sample Output
  
  
6 30


#include<stdio.h>
int main(){
int a,b;
while(scanf("%d%d",&a,&b)&&(a!=0|b!=0))
    {printf("%d\n",a+b);
    }  

return 0;
}


A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 76413    Accepted Submission(s): 40901


Problem Description
Your task is to Calculate the sum of some integers.
 

Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 

Sample Input
  
  
4 1 2 3 4 5 1 2 3 4 5 0
 

Sample Output
  
  
10 15


#include<stdio.h>
int main(){
int n,i, a[200],sum;
  while(scanf("%d",&n)&&n!=0)
{    sum=0;
for( i=0;i<n;i++)

scanf("%d",&a[i]);
sum=sum+a[i];
   }
   printf("%d\n",sum);
   
}

return 0;
}


A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 56776    Accepted Submission(s): 38249


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 

Sample Input
  
  
2 4 1 2 3 4 5 1 2 3 4 5
 

Sample Output
  
  
10 15

#include<stdio.h>
int main(){  
    int n,a[300],i;
    scanf("%d",&n);
    while(n--)
      { int s,sum=0;
      scanf("%d",&s);
      for(i=0;i<s;i++)
         {  scanf("%d",&a[i]);
            sum=sum+a[i];
         }
       printf("%d\n",sum);
      }
 

return 0;
}


A+B for Input-Output Practice (VI)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53108    Accepted Submission(s): 35824


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.
 

Output
For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.
 

Sample Input
  
  
4 1 2 3 4 5 1 2 3 4 5
 

Sample Output
  
  
10 15

#include<stdio.h>
int main(){ 
  int n,a[500] ;
  while(scanf("%d",&n)!=EOF)
    {  int i,sum=0;  
 for(int i=0;i<n;i++)
           {scanf("%d",&a[i]);
             sum=sum+a[i];
           }
           printf("%d\n",sum);
    }

return 0;
}



A+B for Input-Output Practice (VII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52590    Accepted Submission(s): 35249


Problem Description
Your task is to Calculate a + b.
 

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
 

Output
For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.
 

Sample Input
  
  
1 5 10 20
 

Sample Output
  
  
6 30

#include<stdio.h>
int main(){ 
   int a,b,i=0,k,c;
   while(scanf("%d%d",&a,&b)!=EOF)
       {   c=a+b;
          printf("%d\n\n",c);
       }
      
return 0;
}


A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 114481    Accepted Submission(s): 35137


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

Sample Input
  
  
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
 

Sample Output
  
  
10 15 6


#include<stdio.h>
int main(){
int n ,a[100];
scanf("%d",&n);
while(n--)
  {  int s,sum=0;
     scanf("%d",&s);
     for(int i=0;i<s;i++)
        {scanf("%d",&a[i]);
          sum=sum+a[i];
        }
   if(n) 
 printf("%d\n\n",sum);
 else printf("%d\n",sum);
  }
 
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值