HDU水题 A+BII水题

</pre>A + B Problem II</h1><span size="+0" style=""><strong><span style="font-size:12px; font-family:Arial; color:green">Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 261678    Accepted Submission(s): 50648</span></strong></span><div class="panel_title" align="left">Problem Description</div><div class="panel_content">I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.</div><div class="panel_bottom"> </div><div class="panel_title" align="left">Input</div><div class="panel_content">The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.</div><div class="panel_bottom"> </div><div class="panel_title" align="left">Output</div><div class="panel_content">For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.</div><div class="panel_bottom"> </div><div class="panel_title" align="left">Sample Input</div><div class="panel_content"><pre><div style="font-family:Courier New,Courier,monospace">2
1 2
112233445566778899 998877665544332211</div>
 

Sample Output
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 //解题思路:这道题快把折磨疯了,注意输出问题,注意大数相加,我用的是模板,参考代码如下



#include<stdio.h>
#include<string.h>
char a[2000],b[2000];
int  A[2000],B[2000];
int main(){
	 int n,x;
	 scanf("%d",&n);
	 getchar();
	 for(x=1;x<=n;x++)
	  {  int i,j,k,w;
	    printf("Case %d:\n",x);
        scanf("%s%s",a,b);
           k=strlen(a);
           w=strlen(b);
           memset(A,0,sizeof(A));
           memset(B,0,sizeof(B));
        printf("%s + %s = ",a,b);
		 for(j=0,i=k-1;i>=0;i--)
		   {  A[j++]=a[i]-'0';
		   } 
		 for(j=0,i=w-1;i>=0;i--)
		   { B[j++]=b[i]-'0';
	  	   }
	     for(i=0;i<2000;i++)
	     {  A[i]+=B[i];
	       if(A[i]>=10)
	          { A[i]-=10;
	            A[i+1]++;
	          }        
	     }
	     for(i=1999;i>=0&&A[i]==0;i--);
	     for(;i>=0;i--)
	       {printf("%d",A[i]);
	       }
	       printf("\n");
	      if(x!=n)
	       {printf("\n");
	       }
	  


	  
	  }
	
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值