PTA估值一亿的AI核心代码

作者 陈越

单位 浙江大学

AI.jpg

以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 I 和 me 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

字符串模拟, 区间修改版本。

前置知识:

isalnum(char):检查char是否为字母或数字,是返回true。

s.replace(x ,len ,str):将s从第x个开始的len个字母替换为str。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl "\n"

string s;

void gx(string x,string y){//将x替换为y 
	for(ll i = 0 ; ; i ++){
		i=s.find(x,i);
		if(i == -1)break;
		if( !isalnum(s[i-1]) && !isalnum(s[i+x.size()]) )
			s.replace(i ,x.size() ,y);
	}
}

void solve(){
	getline(cin,s);
	cout << s << endl;
	s=" " + s + " ";//为首位加空格,方便后面操作 
	for(ll i = 0 ; i < s.size() ; i ++){
		if(s[i] >= 'A' && s[i] <= 'Z' && s[i] != 'I')s[i] += 32;//大写转小写 
		if(s[i] == ' '){
			while(s[i+1] == ' ')s.erase(s.begin()+i+1);//删去连续空格 
			if(!isalnum(s[i+1]))s.erase(s.begin()+i);//删去符号前的空格 
		}
		if(s[i] == '?')s[i]='!';//转换符号 
	}
	gx("can you","# can");//#为了防止下面的I换了不该换的 
	gx("could you","# could");
	gx("I","you"),gx("me","you");
	gx("# can","I can"),gx("# could","I could");
	if(s[s.size()-1] == ' ')s.erase(s.end()-1);
	if(s[0] == ' ')s.erase(s.begin());
	s="AI: "+s;
	cout << s << endl;
	return;
}

int main(){
	ll t=1;cin >> t;
	cin.get();
	while(t--)solve();
	return 0;
}

字符流操作,输出判断版本。

前置知识:

stringstream str(s):将s以空格分隔,按顺序放入str中。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl "\n"

vector<string>v;

void solve(){
	string s;
	v.clear();
	getline(cin,s);
	cout << s << endl << "AI:";
	for(ll i = 0 ; i < s.size() ; i ++){
		if(isalnum(s[i])){
			if(s[i] != 'I')s[i]=tolower(s[i]);
		}else s.insert(i," "),i++;
		if(s[i] == '?')s[i]='!';
	}
	stringstream str(s);
	while(str >> s)v.push_back(s);
	if(!isalnum(v[0][0]) )cout << " ";
	for(ll i = 0 ; i < v.size() ; i ++){
		if(!isalnum(v[i][0]) )cout << v[i];
		else if( (v[i] == "can" || v[i] == "could") && v[i+1] == "you")cout << " I " << v[i],i++;
		else if(v[i] == "I" || v[i] == "me")cout << " you";
		else cout << " " << v[i];
	}
	cout << endl;
	return;
}

int main(){
	ll t=1;cin >> t;
	cin.get();
	while(t--)solve();
	return 0;
}

  • 3
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值