Basically Speaking

The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features: 
It will have a 7-digit display. 

Its buttons will include the capital letters A through F in addition to the digits 0 through 9. 

It will support bases 2 through 16. 
InputThe input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached. 
OutputThe output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right justified in the display. 
Sample Input
1111000  2 10
1111000  2 16
2102101  3 10
2102101  3 15
  12312  4  2
     1A 15  2
1234567 10 16
   ABCD 16 15
Sample Output
    120
     78
   1765
    7CA
  ERROR
  11001
 12D687
   D071

要细心啊,每个小问题都会导致无法ac,一直找不到问题不通过很难受的

#include <stdio.h>

//atoi:把字符型转化为整型
void convert(char s[],int frombase,int tobase){
    char *p,t[1024];
    long long result=0;
    //atoi:把字符型转化为整型
     p=s;        //注意此处,给p初始化为数组s的第一个值
                 //如果把它写在while()之内,会没有输出
    while(*p){

        result*=frombase;
        if(*p>='0'&&*p<='9')
            result+=*p-'0';
        else if(*p>='A'&&*p<='F')
            result+=*p+10-'A';
        p++;
    }
    int count=0;

    //itoa:把整型转化为字符型
    while(result){
        int val=result%tobase;
        if(val>=0&&val<=9)
            t[count]=val+'0';
        else if(val>=10&&val<=15)
            t[count]=val-10+'A';
        count++;
        result/=tobase; //如果把这块写成val/=tobase,会停止工作;
    }                    //输出也要非常注意
    if(count==0)                    
        printf("      0\n");
    else if(count>7)
        printf("  ERROR\n");
    else{
        int i;
        for(i=count;i<7;i++){
            t[i]=' ';
        }
        for(i=6;i>=0;i--)
            putchar(t[i]);
        putchar('\n');
    }
}

int main(void)
{
    int frombase,tobase;
    char s[1024];
    while(scanf("%s%d%d",s,&frombase,&tobase)!=EOF){ //s之前不用写&
        convert(s,frombase,tobase);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值