HDU 1335 Basically Speaking

http://acm.hdu.edu.cn/showproblem.php?pid=1335

 

Basically Speaking

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 962 Accepted Submission(s): 437


Problem Description
The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.

Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

It will support bases 2 through 16.


 

Input
The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.


 

Output
The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right justified in the display.


 

Sample Input
1111000 2 10 1111000 2 16 2102101 3 10 2102101 3 15 12312 4 2 1A 15 2 1234567 10 16 ABCD 16 15


 

Sample Output
120 78 1765 7CA ERROR 11001 12D687 D071


 

Source


 

Recommend
Ignatius.L
 
题目分析:前面是一个7位的a进制数,转换成后面的进制输出,如果超过7位输出ERROR
分析:进制转换。
代码如下:
#include<iostream>
#include<string>
#include<math.h>
using namespace std;
int fun1(int,int);    //将一个10进制的数转换成要求的进制
int fun2(int);            //将一个已知进制的数转换成10进制
char s[8];                    //保存输入的数据
int x[8];                    //保存输出的数据
int main()
{
  int m,n,len; 
  int t,l,i;
  while(cin>>s)
  {
    len=strlen(s);
    cin>>m>>n;
    t=fun2(m);
    //printf("s=%s m=%d n=%d t=%d\n",s,m,n,t);
    if(fun1(t,n)==-1) cout<<"  ERROR"<<endl;
    else
    {
      l=fun1(t,n);
      for(i=7-l;i>0;i--)
        cout<<' ';
      for(i=l-1;i>=0;i--)
      {
        if(x[i]>=10)
          printf("%c",x[i]-10+'A');                  //这个地方还是用printf好一点。。
        else
          printf("%d",x[i]);
      }
      cout<<'\n';
    }
    memset(s,'\0',sizeof(s));
    memset(x,'\0',sizeof(x));
  }
  return 0;
}
int fun1(int t,int m)
{
  int i=0;
  while(t)
  {
    x[i++]=t%m;
    t=t/m;
    if(i==8) return -1;
  }
  return i;
}
int fun2(int m)
{
  int len=strlen(s);
  int i,t=0;
  for(i=len-1;i>=0;i--)
  {
    if(s[i]>='A')
      s[i]=s[i]-'A'+10;
    else
      s[i]=s[i]-'0';
    t+=s[i]*pow(m,len-1-i);
  }
  return t;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值