Frogger poj 2253 dijkstra

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39419 Accepted: 12682

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2

Frog Distance = 1.414

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;

typedef long long LL;
const int N=1002;

int x[N],y[N];
double gra[N][N];
double dist[N];
int vis[N];
double ans;

void dijkstra(int n)
{
    for(int i=1;i<=n;i++)
    {
        dist[i]=INF;
        vis[i]=0;
    }
    dist[1]=0;
    for(int i=1;i<=n;i++)
    {
        int pos=-1;
        double minn=INF;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dist[j]<minn)
            {
                minn=dist[j];
                pos=j;
            }
        }
        if(ans<minn)
            ans=minn;
        if(pos==2) break;
        vis[pos]=1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dist[j]>gra[pos][j])
            {
                dist[j]=gra[pos][j];
            }
        }
    }

}

int main()
{
    int n;
    int cas=0;
    while(scanf("%d",&n)==1)
    {
        if(n==0) break;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",x+i,y+i);
        }
        for(int i=1;i<=n;i++){
            for(int j=i+1;j<=n;j++){
                gra[i][j]=gra[j][i]=(double)sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
            }
        }
        ans=0;
        dijkstra(n);
        printf("Scenario #%d\nFrog Distance = %.3f\n\n",++cas,ans);
    }
    return 0;
}



#include<iostream>
#include<math.h>
#include<iomanip>
using namespace std;

class coordinate
{
public:
    double x,y;
}point[201];

double path[201][201];   //两点间的权值

int main(void)
{
    int i,j,k;

    int cases=1;
    while(cases)
    {
        /*Read in*/

        int n;   //numbers of stones;
        cin>>n;
        if(!n)break;

        for(i=1;i<=n;i++)
            cin>>point[i].x>>point[i].y;

        /*Compute the weights of any two points*/

        for(i=1;i<=n-1;i++)
            for(j=i+1;j<=n;j++)
            {
                double x2=point[i].x-point[j].x;
                double y2=point[i].y-point[j].y;
                path[i][j]=path[j][i]=sqrt(x2*x2+y2*y2);  //双向性
            }

        /*Floyd Algorithm*/

        for(k=1;k<=n;k++)    //k点是第3点
            for(i=1;i<=n-1;i++)    //主要针对由i到j的松弛,最终任意两点间的权值都会被分别松弛为最大跳的最小(但每个两点的最小不一定相同)
                for(j=i+1;j<=n;j++)
                    if(path[i][k]<path[i][j] && path[k][j]<path[i][j])    //当边ik,kj的权值都小于ij时,则走i->k->j路线,否则走i->j路线
                        if(path[i][k]<path[k][j])               //当走i->k->j路线时,选择max{ik,kj},只有选择最大跳才能保证连通
                            path[i][j]=path[j][i]=path[k][j];
                        else
                            path[i][j]=path[j][i]=path[i][k];

        cout<<"Scenario #"<<cases++<<endl;
        cout<<fixed<<setprecision(3)<<"Frog Distance = "<<path[1][2]<<endl;
        //fixed用固定的小数点位数来显示浮点数(包括小数位全为0)
        //setprecision(3)设置小数位数为3
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值