Prime Path poj bfs 3126

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18284 Accepted: 10291

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source


#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
using namespace std;
const int Max=10100;
int prime[Max];
int vis[Max];
int judge,sum;
struct node{
int num,step;
};
queue<node>q;
node a,b;
void bfs()
{
   q.push(a);
   while(!q.empty())
   {
     node p=q.front();
     q.pop();
     if(p.num<=1000||vis[p.num]||prime[p.num]) continue;
     vis[p.num]=1;
     if(p.num==b.num)
     {
       judge=1;sum=p.step;return;
     }
     for(int i=1;i<10;i++)
     {
       node t;
       t.num=(p.num+1000*i)%10000;
       t.step=p.step+1;
       q.push(t);
       t.num=(p.num/1000)*1000+(p.num%1000+100*i)%1000;
       q.push(t);
       t.num=(p.num/100)*100+(p.num%100+10*i)%100;
       q.push(t);
       t.num=(p.num/10)*10+(p.num%10+i)%10;
       q.push(t);
     }
   }
}
int main()
{
  prime[0]=prime[1]=0;
  for(int i=2;i<10001;i++)
  {
    if(prime[i]==0)
    {
      for(int j=i;j*i<10001;j++)
      prime[i*j]=1;
    }
  }
  int t;
  cin>>t;
  while(t--)
  {
     sum=judge=0;
      while(!q.empty()) q.pop();
     memset(vis,0,sizeof(vis));
     cin>>a.num>>b.num;
     if(a.num==b.num)
     {
      printf("0\n");continue;
     }
     bfs();
     if(judge)
     {
        printf("%d\n",sum);
     }
     else
     {
      printf("Impossible\n");
     }
  }
}

    思路:用BFS暴搜,每次改变一位数如果是素数就进入队列,
    但是暴搜的前提要把1w以内的素数筛出来。为了方便对每一位上的数的操作,
    本人用的字符串来储存4位数字。


#include <iostream>
#include<queue>
#include<cstring>
#include<cstdio>
using namespace std;
int prime[100005];
int flag[100004];
struct node{
char str[6];
int step;
};
void getprime()
{
  for(int i=2;i<=10000;i++)
  {
    if(prime[i]==0)
    {
      for(int j=i;j*i<10001;j++)
      prime[i*j]=1;
    }
  }
}
int bfs(char *x,char *y)
{
  if(strcmp(x,y)==0) return 0;
  queue<node>q;
  int i,j,num,step;
  char ch;
  node t;
  strcpy(t.str,x);
  t.step=0;
  num=(t.str[0]-'0')*1000+(t.str[1]-'0')*100+(t.str[2]-'0')*10+(t.str[3]-'0');
  flag[num]=1;
  q.push(t);
  while(!q.empty())
  {
   t=q.front();
   step=t.step;
    q.pop();
    for(i=0;i<4;i++)
    {
      ch=t.str[i];
      i==0?j='1':j='0';
      for(;j<='9';j++)
      {
         if(j==ch) continue;
         t.str[i]=j;
         t.step=step+1;
         if(strcmp(t.str,y)==0) return t.step;
          num=(t.str[0]-'0')*1000+(t.str[1]-'0')*100+(t.str[2]-'0')*10+(t.str[3]-'0');
          if(!prime[num]&&!flag[num])
          {
           flag[num]=1;
           q.push(t);
          }
      }
      t.str[i]=ch;
    }
  }
  return -1;
}
int main()
{
    getprime();
    int t,step;
    char x[6],y[6];
    cin>>t;
    while(t--)
    {
       memset(flag,0,sizeof(flag));
       cin>>x>>y;
       step=bfs(x,y);
       if(step!=-1)
       printf("%d\n",step);
       else 
       printf("Impossible\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值