寒假前刷题(8)搜索系列 dfs hdu 1241

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6187    Accepted Submission(s): 3590


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
这是一道典型的dfs的题目,不过笔者还是愚笨了,没能独立的刷出来这道题,这个题就是个递归的思想,往一个格的八个方向来搜索。
下面的是代码:

#include<stdio.h>
#include<string.h>
#include<iostream>

using namespace std;

char map[101][101];
int n,m,sum;

void dfs(int x,int y)
{
     if(map[x][y]!='@'||x<0||y<0||x>=m||y>=n)//如果所搜索的不行或越界,就返回
           return;
          map[x][y]='!';//标记为已访问过,如果可以话,就往它的八个方向来进行深搜
          dfs(x-1,y+1);
          dfs(x-1,y);
          dfs(x-1,y-1);
          dfs(x,y-1);
          dfs(x+1,y-1);
          dfs(x+1,y);
          dfs(x+1,y+1);
          dfs(x,y+1);
}

int main()
{
     int i,j;

     while(cin>>m>>n)
     {
          if(m==0&&n==0)
            break;
            sum=0;
          for(i=0;i<m;i++)
            for(j=0;j<n;j++)
              cin>>map[i][j];
          for(i=0;i<m;i++)
          {
               for(j=0;j<n;j++)
               {
                  if(map[i][j]=='@')
                  {
                     dfs(i,j);
                     sum++;
                  }
               }
          }
           cout<<sum<<endl;
     }
     return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值