HDU 3349

lazy gege
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1391 Accepted Submission(s): 586

Problem Description
Gege hasn’t tidied his desk for long,now his desk is full of things.
This morning Gege bought a notebook,while to find somewhise to put it troubles him.
He wants to tidy a small area of the desk, leaving an empty area, and put the notebook there, the notebook shouldn’t fall off the desk when putting there.
The desk is a square and the notebook is a rectangle, area of the desk may be smaller than the notebook.
here’re two possible conditions:

这里写图片描述
Can you tell Gege the smallest area he must tidy to put his notebook?

Input
T(T<=100) in the first line is the case number.
The next T lines each has 3 real numbers, L,A,B(0< L,A,B <= 1000).
L is the side length of the square desk.
A,B is length and width of the rectangle notebook.

Output
For each case, output a real number with 4 decimal(printf(“%.4lf”,ans) is OK), indicating the smallest area Gege should tidy.

Sample Input

3
10.1 20 10
3.0 20 10
30.5 20.4 19.6

Sample Output

25.0000
9.0000
96.0400

题解:
为了将书放在桌子上并尽可能小的占用空间,当重心放在上面即可;
沿着桌子的棱角去放书,三种情况:
1:这里写图片描述
2:这里写图片描述
3:这里写图片描述

代码:

#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
    int T;
    cin >>T;
    while(T--){
        double L,A,B;
        cin >> L >>A >> B;
        double x;
        x=L/sqrt(2);
        double Min;
        Min=min(A,B);
        double s;
        if(x>=Min/2) {
            s=Min*Min/4;
        }
        else if(x*2<=Min/2){
            s=L*L;
        }
        else {
            s=L*L-(sqrt(2)*L-Min/2)*(sqrt(2)*L-Min/2);
        }
        printf("%.4f\n",s);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值