hdu 3349 lazy gege

lazy gege

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 653    Accepted Submission(s): 276


Problem Description
Gege hasn't tidied his desk for long,now his desk is full of things.
This morning Gege bought a notebook,while to find somewhise to put it troubles him.
He wants to tidy a small area of the desk, leaving an empty area, and put the notebook there, the notebook shouldn't fall off the desk when putting there.
The desk is a square and the notebook is a rectangle, area of the desk may be smaller than the notebook.
here're two possible conditions:

Can you tell Gege the smallest area he must tidy to put his notebook?
 

Input
T(T<=100) in the first line is the case number.
The next T lines each has 3 real numbers, L,A,B(0< L,A,B <= 1000).
L is the side length of the square desk.
A,B is length and width of the rectangle notebook.
 

Output
For each case, output a real number with 4 decimal(printf("%.4lf",ans) is OK), indicating the smallest area Gege should tidy.
 

Sample Input
  
  
3 10.1 20 10 3.0 20 10 30.5 20.4 19.6
 

Sample Output
  
  
25.0000 9.0000 96.0400
 


绝逼水题啊,分三种情况讨论


#include<stdio.h> 
#include<math.h>  
int main()  
{  
    int T;  
    double l,a,b,t;  
    scanf("%d",&T);  
    while(T--)  
    {  
        scanf("%lf%lf%lf",&l,&a,&b);  
        if(a>b)  t=b;
		else t=a;
        double k=sqrt(2.0)*l;
        if(k<t/2)  printf("%.4lf\n",l*l);  
        else 
		{	
			if(t/2<k/2)  
				printf("%.4lf\n",t*t/4); 
            else 
                printf("%.4lf\n",l*l-(k-t/2)*(k-t/2));  
        }  
    }  
    return 0;  
}  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值