POJ-2492 A Bug's Life (种类并查集)

A Bug’s Life
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint
Huge input,scanf is recommended.

题意:给T个测试样例,n个虫子和m个行为,判断其中是否存在同性相交
假设x与x+n是相反的性别,因此需要开2*n的数组
通过并查集将同一性别的放在一个集合,设A与B交配,那么判断A与B或者A+n与B+n是否为异性,一旦出现同性相交往后就只读数据不用测试了。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
//设x,与x+n为异性
const int maxn = 2000+10;
int T,n,m;
int per[2*maxn];
int Find(int x){
    int cx=x;
    while(cx!=per[cx]){
        cx=per[cx];
    }
    int i=x,j;
    while(i!=cx){
        j=per[i];
        per[i]=cx;
        i=j;
    }
    return cx;
}
//这里是把同性加入同一集合中
void Union(int x,int y)
{
    int cx = Find(x);
    int cy = Find(y);
    if(cx!=cy){
        per[cy]=cx;
    }
}
//判断是否在同一集合,即判断是否同一性别
bool judge(int x,int y)
{
    int cx = Find(x);
    int cy = Find(y);
    if(cx!=cy) return true;//异性返回true
    else return false;
}
int main()
{
    scanf("%d",&T);
    int kase=1;
    while(T--){
        //memset(per,0,sizeof(per));

        scanf("%d %d",&n,&m);

        for(int i=0;i<=2*n;i++)
            per[i]=i;

        int x,y;
        bool f = true;
        for(int i=1;i<=m;i++){
            scanf("%d %d",&x,&y);
            //x与y交配
            //正常是x与y为异性,所以判断x与y+n或者y与x+n
            if(f&&(judge(x,y)||judge(x+n,y+n))){
                Union(x,y+n);
                Union(y,x+n);
            }
            else{
                //cout << "meijinlai?" << endl;
                f=false;
            }
        }
       // for(int i=1;i<=2*n;i++)
        //    printf("%d ",per[i]);
        //cout << endl;
        if(kase>1)
            printf("\n");
        printf("Scenario #%d:\n",kase++);
        if(f) printf("No suspicious bugs found!\n");
        else printf("Suspicious bugs found!\n");
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值