POJ 3250 Bad Hair Day (单调栈)

Bad Hair Day

Some of Farmer John’s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows’ heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow’s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow’s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input
Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Line 1: A single integer that is the sum of c 1 through cN.
Sample Input
6
10
3
7
4
12
2
Sample Output
5

题意:有N头牛,给N头牛的高度,每头牛都超右看其他牛的头顶,当高度大于时才能看到,问所有牛能看到和。
a[i]存高度,每一头牛能看到个数是往右数到第一个不小于它高度的牛的个数
反过来,每一头牛能被多少只牛看到,它的和也是这个问题得解;
所以对于每一头牛,用book[i]数组存能被多少头牛看到,这样求解往左边找比自己高的而且要递增。假如i < j , a[i] > a[j];第i个数是第j个数左边第一个大于自己的数,所以book[j]=book[i]+1;所以不用一直从j找到1,只需找到第一个比自己高的即可

代码

#include<iostream>
#include<stdio.h>
#define ll long long
#include<algorithm>
using namespace std;
const int maxn = 80000+10;

ll a[maxn];
int book[maxn];
ll sum=0;
int main()
{
    int n;
    scanf("%d",&n);

    book[0]=-1;
    for(int i=1;i<=n;i++)
    {
        scanf("%lld",&a[i]);
        int top=i-1;
        int ans=0;
        while(a[top]<=a[i]&&i!=top&&top>0){
            top--;
        }
        //printf("%d\n",top);
        book[i]=book[top]+1;
        sum+=book[i];
    }

    printf("%lld",sum);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值