HDU 2056 rectangles

Rectangles

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14474    Accepted Submission(s): 4675


Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
 

Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
 

Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
 

Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
 

Sample Output
1.00
56.25
本题大意是给出 一个矩形的一条对角线点的坐标,求两个矩形的重叠面积;
思路:我的方法主要是利用结构体。对给出的四个横坐标,和四个纵坐标按降序排列,中间的两个横坐标和纵坐标围城的区域即是重叠的面积(最大的两个横坐标属于同一矩形或最大的两个纵坐标属于同一个矩形排除);
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
       double z;
       int a;
};
node x[100],y[100];
bool cmp(node x,node y)
{
     return x.z>y.z;
}
int main()
{
    int i,j;
    while(~scanf("%lf %lf",&x[0].z,&y[0].z))
    {
                     double sum=0;
                     for(i=1;i<=3;i++)
                     {
                                     scanf("%lf %lf",&x[i].z,&y[i].z);
                     }
                     x[0].a=x[1].a=1;
                     y[0].a=y[1].a=1;
                     x[2].a=x[3].a=2;
                     y[2].a=y[3].a=2;//用于判断最大的两个是否属于同一矩形。
                     sort(x,x+4,cmp);
                     sort(y,y+4,cmp);
                     if(x[0].a==x[1].a||y[0].a==y[1].a)
                     {
                                               printf("0.00\n");
                                               continue;
                     }
                     else
                     {
                         sum=(x[1].z-x[2].z)*(y[1].z-y[2].z);
                         printf("%.2lf\n",sum);
                     }
                    
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值