栈,汽车进站出站:poj 1363 rails

Rails

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24953 Accepted: 9779

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes
最基础的栈类型问题。本题分为可以三部分,一是进站,二是保存在栈中(中转站),三是出站;
 
思路:定义三个数组,分别储存进站车辆,出站车辆,和中转车辆,用表示进站车辆的数组下标来控制程序的结束与否,用表示栈数组下标的变量来判断输出结果;
代码:
#include<stdio.h>  
#include<string.h>
int a[1100];//进站车辆
int stck[1100];//栈数组
int s[1100];//出站顺序数组
int main()
{
    int n,t;
    while(~scanf("%d",&n)&&n!=0)
    {
                          int i;
                          for(i=1;i<=n;i++)
                          a[i]=i;
                          i=1;
                          while(~scanf("%d",&s[i])&&s[i]!=0)
                          {
                                                   int j,k=1,t=0,l=1;
                                                   memset(stck,0,sizeof(stck));
                                                   for(i=2;i<=n;i++)
                                                   scanf("%d",&s[i]);
                                                   for(i=1,k=1;l<=n;l++)
                                                   {
                                                                        if(a[l]==s[i])
                                                                        {
                                                                           i++;
                                                                           while(s[i]==stck[k-1]&&k!=1)
                                                                            {
                                                                                               k--;
                                                                                               i++;
                                                                            }
                                                                        }
                                                                        else
                                                                          {stck[k++]=a[l];}//对暂时不能出站的存在栈数组中
                                                                        
                                                   }
                                                   //printf("%d\n",k);
                                                   //printf("%d %d\n",s[1],a[1]);
                                                   if(k==1)
                                                   printf("Yes\n");
                                                   else
                                                   printf("No\n");
                                                   i=1;
                                                   memset(s,0,sizeof(s));
                          }
                          
                          printf("\n");
    }
    return 0;
}
下面用栈写的:
#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;
int a[1100];
int main(){
	int n;
	while(~scanf("%d",&n)&&n){
		memset(a,0,sizeof(a));
		int i,j,k;
		while(~scanf("%d",&a[0])&&a[0]!=0){
		stack<int> sta;
			for(i=1;i<n;i++){
				scanf("%d",&a[i]);
			}
			k=0;
			sta.push(1);
			for(i=1;i<=n&&k<n;){
			//	sta.push(i);
				if(!sta.empty()&&sta.top()==a[k]){
					k++;
					sta.pop();
				    
				}
				else{
				    i++;
				    if(i<=n)
					sta.push(i);//printf("%d\n",i);
					
				}
			}
//			printf("$%d\n",sta.size());
//			while(!sta.empty()){printf("right\n");
//				printf("%d ",sta.top());
//				sta.pop();
//			}
			
			if(!sta.empty()){
				printf("No\n");
			}
			else
			printf("Yes\n");
			memset(a,0,sizeof(a));
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值