杭电4496D-City

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2147    Accepted Submission(s): 758


Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

Sample Input
  
  
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

Sample Output
  
  
1 1 1 2 2 2 2 3 4 5
反向并查集;
#include<stdio.h>
#include<string.h>
int f[100100];
int N,M;
int a[100100];
struct node{
	int x;
	int y;
}s[100100];
int fun(){
	int i,j;
	int sum=0;
	for(i=0;i<N;i++){
		if(f[i]==i)
		sum++;
	}
	return sum;
}
void w(){
	int i,j;
	for(i=0;i<N;i++){
		f[i]=i;
	}
}
int find(int x){
	return f[x]==x?x:f[x]=find(f[x]);
}
int main(){
	while(~scanf("%d %d",&N,&M)){
		int i,j,k;
		for(i=0;i<M;i++){
			scanf("%d %d",&s[i].x,&s[i].y);
		}
//		for(i=0;i<M;i++){
//		    
//			for(j=i+1;j<=M;j++){
//				if(find(s[j].x)!=find(s[j].y)){
//					f[s[j].x]=s[j].y;
//				}
//				//merge(s[j].x,s[j].y);
//			}
//			printf("%d\n",fun());
//		}
		w();
		int all=N;
		a[0]=all;
		j=0;
		for(i=M-1;i>0;i--){
			int t1=find(s[i].x);
			int t2=find(s[i].y);
			if(t1!=t2){
				f[t1]=f[t2];
				all--;
			}
			a[++j]=all;
		}
		for(j=j;j>=0;j--){
			printf("%d\n",a[j]);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值