D、City

Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

Sample Output
1
1
1
2
2
2
2
3
4
5

题目大意:有n个点,m条线,每条线连接两个点,由线连接起来的点若干个点算一块,问每删去一条线后,点被分成多少块。

必备知识:并查集:参考博客:并查集详解 (转)

可以看成从最后0条线开始,每增加一条线后,点被分成几块

#include <stdio.h>
#include <string.h>

int pre[10005];
int line[100005][2];
int ans[100005];

int find(int x)
{
    int r = x;
    while (pre[r] != r)
        r = pre[r];

    int j = x, k;

    while (pre[j] != r)
    {
        k = pre[j];
        pre[j] = r;
        j = k;
    }

    return r;
}

int join(int x,int y)
{

    int fx = find(x),fy = find(y);
    if (fx != fy)
    {
        pre[fx] = fy;
        return 1;
    }
    return 0;
}

int main()
{
    int n,m;
    while (scanf("%d%d",&n,&m) != EOF)
    {
        memset(pre,0,sizeof(pre));
        memset(line,0,sizeof(line));
        memset(ans,0,sizeof(ans));
        for (int i = 0; i < 10005; i++)
        {
            pre[i] = i;
        }

        for (int i = 0; i < m; i++)
        {
            scanf("%d%d",&line[i][0],&line[i][1]);
        }

        int sum = n;

        for (int i = 0; i < m; i++)
        {
            ans[i] = sum;
            sum -= join(line[m-i-1][0],line[m-i-1][1]);
        }

        for (int i = m-1; i >= 0; i--)
        {
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值