2013 ACM 通化邀请赛D.D-City 并查集

点击打开链接

D.D-City
Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line 
connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants 
to know how many connected blocks of D-city left after Luxer destroying the first K D-lines 
in the input.
Two points are in the same connected blocks if and only if they connect to each other 
directly or indirectly.
Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which 
denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.


Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4


Sample Output
1
1
1
2
2
2
2
3
4
5


Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge 
connecting them, so there's only 1 connected block at first. The first 3 lines of output are 
1s because after deleting the first 3 edges of the graph, all vertexes still connected 
together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with 
other vertex, and it became an independent connected block. Continue deleting edges the 
disconnected blocks increased and finally it will became the number of vertex, so the last 
output should always be N.

反向其实就是一个并查集的合并操作,。听说正向BFS可破,但是没试过

#include<stdio.h>
#include<string.h>
int dele[100010][2];
int father[10010];
int mystack[100010];
int top;
int count;
int getfather(int i)
{
	if(father[i] == i)
		return i;
	else
		return  father[i] = getfather(father[i]);
}
void merge(int a, int b)
{
	a = getfather(a);
	b = getfather(b);
	if(a == b)
		return;
	else 
	{
		father[b] = a;
		count --;
	}
}
int main()
{
	int n, m;
	while(scanf("%d%d", &n, &m) != EOF)
	{
		int i;
		memset(dele, 0, sizeof(dele));
		for(i = 0; i < m; i++)
			father[i] = i;
		for(i = 0; i < m ; i++)
			scanf("%d%d", &dele[i][0], &dele[i][1]);
		count = n;
		top = 0;
		for(i--; i >= 0; i --)
		{
			mystack[top++] = count;
			merge(dele[i][0], dele[i][1]);
		}
		for(top --; top >= 0; top--)
		{
			printf("%d\n", mystack[top]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值