Ignatius and the Princess IV——伊格纳提乌斯和四公主

12 篇文章 0 订阅
7 篇文章 0 订阅

Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

 

 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

 

 

Output

For each test case, you have to output only one line which contains the special number you have found.

Sample Input

5

1 3 2 3 3

11

1 1 1 1 1 5 5 5 5 5 5

7

1 1 1 1 1 1 1

Sample Output

 3

5

1

Author

Ignatius.L

题意:

问题描述

"好吧,你不是太坏,嗯...但你永远不能通过下一个测试。"冯5166说。

"我会告诉你一个奇数n,然后n个整数。其中会有个特殊的整数,在我告诉你所有的整数之后,你必须告诉我哪个是特殊的整数。”冯5166说。

"但是特殊整数的特性是什么?"他问。

"整数至少会出现(n+1)/2次。如果你找不到合适的整数,我会杀了公主,你也会成为我的晚餐。“冯5166说。

你能为伊格纳提找到一个特殊的整数吗?

输入:

输入包含几个测试用例。每个测试用例包含两行。第一行由奇数整数n(1<=n<=999999)组成,这表示整数的数目,冯5166将告诉我们的英雄。第二行包含n个整数。输入在文件结束时终止。

输出:

对于每个测试用例,您只能输出一行,其中包含您找到的特殊编号。

AC码:

方法一:

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1000000;
int a[maxn];
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		sort(a,a+n);
		printf("%d\n",a[n/2]);
	}
	return 0;
}

方法二:

#include<stdio.h>
#include<string.h>
int map[500001];//记录[i]出现的次数 
int main()
{
int n,i,a,max;
while(scanf("%d",&n)!=EOF)
{
memset(map,0,sizeof(map));
for(i=0;i<n;i++)
{
scanf("%d",&a);
map[a]++;
if(map[a]>=(n+1)/2)
max=a;
}
printf("%d\n",max);
}
return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值