HDU steps 1.2.7 AC Me

分析:这个题算法上没有什么难度,主要在于考察基本字符串,基本控制的运用。在java中,1、有判断是否为字母的函数“Character.isLowerCase(s.charAt(i))” ; 

2、map容器可以很方便的存储计算的结果,用到了map.put(),map.get(), map.containsKey().  其中当想要修改value的值时,可以先get,再put覆盖。

3、get(Object key)
返回指定键所映射的值;如果此映射不包含该键的映射关系,则返回 null

AC Me

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4644 Accepted Submission(s): 1620
 
Problem Description
Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.

It's really easy, isn't it? So come on and AC ME.
 
Input
Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.

Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file.
 
Output
For each article, you have to tell how many times each letter appears. The output format is like "X:N". 

Output a blank line after each test case. More details in sample output.
 
Sample Input
hello, this is my first acm contest!
work hard for hdu acm.
 
Sample Output
a:1
b:0
c:2
d:0
e:2
f:1
g:0
h:2
i:3
j:0
k:0
l:2
m:2
n:1
o:2
p:0
q:0
r:1
s:4
t:4
u:0
v:0
w:0
x:0
y:1
z:0

a:2
b:0
c:1
d:2
e:0
f:1
g:0
h:2
i:0
j:0
k:1
l:0
m:1
n:0
o:2
p:0
q:0
r:3
s:0
t:0
u:1
v:0
w:1
x:0
y:0
z:0
 
Author
Ignatius.L
 
Source
杭州电子科技大学第三届程序设计大赛
 
Recommend
Ignatius.L

代码:

import java.util.HashMap;
import java.util.Map;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Map<Character, Integer> map = new HashMap<Character, Integer>();
		Scanner in = new Scanner(System.in);
		while (in.hasNext()) {
			map.clear();
//			System.out.println("!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!");
			String s = in.nextLine();
			for (int i = 0; i < s.length(); i++) {
				if (Character.isLowerCase(s.charAt(i))) {
					if(map.containsKey(s.charAt(i))){
						int n = map.get(s.charAt(i));
						map.put(s.charAt(i), n+1);
					}
					else{
						map.put(s.charAt(i),1);
					}
				}
			}
			
			for(int i='a';i< 'a'+26;i++){
				if(map.containsKey((char)i)){
					System.out.println((char)i+":"+map.get((char)i));
				}
				else{
					System.out.println((char)i+":"+0);
				}
			}
			System.out.println();
//			System.out.println("----------------------------------");
		}
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值