HDOJ 1005

Number Sequence


Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

Author

CHEN, Shunbao

Source

ZJCPC2004


看到n的范围,应该能想到此题决不能直接借助所给的递归方程直接求解,那样将肯定超时。
所以肯定有循环存在,观察到开始有两个一,结合递归方程不难猜出,当再出现1,1时,将进入循环,建议先编写小程序,观察数值,找出循环,即可解题。
代码:
#include<stdio.h>
int main()
{
    int f[150]={1,1,1};    //初始值,f[1]=1,f[2]=1
    
    int i,k,a,b,n;

    while(scanf("%d%d%d",&a,&b,&n)&&(a||b||n))  //输入并判断
    {
        for(i=3;i<150;i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            if(f[i]==1&&f[i-1]==1) break;     //出现循环的条件
        }
        i=i-2;        //将1,1除去,不在循环范围内
        k=n%i;				
        if(k==0) k=i;
        printf("%d\n",f[k]);
    }   
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值