POJ - 1611 The Suspects (并查集 查找同一集合元素)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
 
 
题意:
    03年SARS病毒,使得编号为0的同学始终为感染者,现在给你N个同学,编号为0~N-1;再给M个讨论组,每组第一个数为该组人数,剩余数为该组同学编号。一个同学可以同时在多个讨论组里。题意为与0号同学一组的都会被感染,而被感染的同学在其他组的话,那一组的同学也都被感染(传递性)。求最后被感染的同学数。
 
 
解题思路:
    其实就是将N个同学编入集合,看谁和0号同学在一个集合中,集合中元素的个数就是感染同学数。
 
 
注意:
    最后查找是否在一个集合中时应该回溯到该同学的根节点,看是否是一个根节点,是的话说明是一个集合。
 
 
AC代码:
#include<stdio.h>
#include<string.h>

int f[30010];  //存储每个同学的结点

int getf( int v )
{
    if( v != f[v] )
        f[v] = getf(f[v]);
    return f[v];
}

void pan( int x1, int x2 )
{
    int t1 = getf(x1);
    int t2 = getf(x2);
    if( t1 != t2 )
        f[t2] = t1;
}

int main()
{
    int n, m;
    while( scanf("%d%d",&n,&m) && (n+m) )
    {
        for( int i = 0; i < n; i++ )
            f[i] = i;            //初始化编号,从0开始
        for( int i = 0; i < m; i++ )
        {
            int rr, s1, s2;
            scanf("%d%d",&rr,&s1); //输入组内人数与第一个同学编号
            for( int j = 1; j < rr; j++ )
            {
                scanf("%d",&s2);
                pan(s1,s2);    //让第一个同学与其他同学建立联系
            }
        }
        int sum = 1;
        for( int i = 1; i < n; i++ )
        {
            if( getf(f[i]) == getf(f[0]) ) //回溯到根节点判断
                sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值