POJ - 2367 Genealogical tree (拓扑排序模板题)

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
Input
The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.
Output
The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.
Sample Input
5
0
4 5 1 0
1 0
5 3 0
3 0
Sample Output
2 4 5 3 1
 
 
 
 
题意:
    意思就是,火星人的血缘关系特别混乱。一个人可能好多儿子,儿子也好多儿子~~~~。所以我们的任务就是,帮助他们建立一个族谱,确定“家庭关系”。输入首先为一个整数,表示1~N号火星人,接下来N行每行输入以0结尾,0之前的表示这一个火星人的儿子编号。
 
 
解题思路:
    明白题意后这就是一个拓扑排序的模板题,裸的拓扑排序。因为没有特殊的优先级,只需确定次序,可以用队列也可以用数组。构造成图就是一个简单的有向图,关键就是,记录每个点的入度,有入度就代表有“父亲”,所以<每次要找到入度为0的点,把以这个点起始的路径删除>,重复“<>”内的操作。具体数组和队列的实现看程序注释。
 
 
队列AC代码:
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

int mp[110][110];
int n, in[110], book[110];

void toposort( )
{
    memset(book,0,sizeof(book));
    queue<int>Q;  //创建队列
    for( int i = 1; i <= n; i++ )
    {
        if( !in[i] )  
        {
            Q.push(i);   //将入度为0的点加入队列
            book[i] = 1;  //标记这个点以后不加入队列
        }
    }
    int g = 1;
    while( Q.size() )
    {
        int v = Q.front(); //取队列的第一个元素
        Q.pop();  //取出后删除
        if( g < n )
            printf("%d ",v);
        else       //控制输出格式
            printf("%d\n",v);
        g++;
        for( int i = 1; i <= n; i++ )
        {
            if( mp[v][i] )  //删除路径
            {
                in[i]--;
                if( !in[i] && !book[i] )
                {
                    Q.push(i);//在删除路径过程中有入度为0
                    book[i] = 1;//且没被标记的加入队列并标记
                }
            }
        }
    }
}

int main()
{
    while( ~scanf("%d",&n) )
    {
        memset(mp,0,sizeof(mp));
        memset(in,0,sizeof(in));
        for( int i = 1; i <= n; i++ )
        {
            int s;
            while( scanf("%d",&s) && s )
            {
                mp[i][s] = 1; //构造有向图
                in[s]++;     //记录点的入度
            }
        }
        toposort();
    }
    return 0;
}


数组AC代码:
#include<stdio.h>
#include<string.h>

int c[110], topo[110];//c数组标记,topo数组保存排序
int mp[110][110], n;
int in[110]; //记录入度

void toposort( )
{
    int v;
    for( int j = 1; j <= n; j++ )//总共找n次入度为0的点
    {
        for( int i = 1; i <= n; i++ )
        {
            if( !c[i] && in[i] == 0 )
            {
                v = i; //找到一个入度为0且没被标记的
                break; //就记录然后挑出
            }
        }
        topo[j] = v;  //保存排序
        c[v] = 1;
        for( int i = 1; i <= n; i++ )
        {
            if( mp[v][i] )
            in[i]--; //删除路径
        }
    }
    for( int j = 1; j < n; j++ )
        printf("%d ",topo[j]);
    printf("%d\n",topo[n]);//控制输出格式
}

int main()
{
    while( ~scanf("%d",&n) )
    {
        int x;
        memset(mp,0,sizeof(mp));
        memset(in,0,sizeof(in));
        memset(c,0,sizeof(c));
        for( int i = 1; i <= n; i++ )
        {
            while( scanf("%d",&x) && x )
            {
                mp[i][x] = 1;//构造有向图
                in[x]++;//记录入度
            }
        }
        toposort();
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值