1155 Heap Paths (30分) HEAP 深搜回溯 堆 DFS 保存路径

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

作者

陈越

单位

浙江大学

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

大意:一个堆,且符合完全二叉树,给出树的层序遍历,若从根到叶子结点的每一条路径上的值都是非递减的,此堆即为Min Heap,反之为Max Heap。问是Min Heap还是Max Heap还是Not Heap?

一刷:柳:

#include <iostream>
#include <vector>

using namespace std;

int a[10006],n,isMin=1,isMax=1;
vector<int> v;
void dfs(int index)
{
	if (index*2>n)
	{
		if (index<=n)
		{
			for (int i = 0; i < v.size(); i++)
			{
				printf("%d%s", v[i], i == v.size() - 1 ? "\n" : " ");
			}
		}
	}
	else
	{
		v.push_back(a[index*2+1]);
		dfs(index * 2 + 1);
		v.pop_back();
		v.push_back(a[index * 2]);
		dfs(index * 2);
		v.pop_back();
	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	cin >> n;
	for (int i = 1; i <= n; i++)
	{
		cin >> a[i];
	}
	v.push_back(a[1]);
	dfs(1);
	for (int i = 2; i <= n; i++)
	{
		if (a[i/2]>a[i])
		{
			isMin = 0;
		}
		if (a[i/2]<a[i])
		{
			isMax = 0;
		}
	}
	if (isMin==1)
	{
		printf("Min Heap\n");
	}
	else
	{
		printf("%s Heap\n", isMax == 1 ? "Max" : "Not");
	}
	return 0;
}

二刷:吾:(思路:先发所有路径遍历一遍,保存在path里。然后一条条路径判断,先通过开头v[1]和v[2]的比较,姑且得到一个max还是min的判断,然后遍历路径,路径中有不符合初始判断的,即Not Heap,否则说明都符合初始判断,即初始判断没问题)

#include <iostream>
#include <vector>

using namespace std;

vector<int> path[1006],temppath;
vector<int> v;

int n,cnt=1;


void dfs(int v)
{
	if (v<=n)
	{
		temppath.push_back(v);
	}
	if (v*2+1<=n)
	{
		dfs(v * 2 + 1);
	}
	if (v*2<=n)
	{
		dfs(v * 2);
	}
	if (v*2>n&&v*2+1>n)
	{
		path[cnt] = temppath;
		
		cnt++;
	}
	temppath.pop_back();
}

int main()
{
	//freopen("in.txt", "r", stdin);

	cin >> n;
	v.resize(n + 1);
	for (int i = 1; i <= n; i++)
	{
		cin >> v[i];
	}
	dfs(1);
	int sum = 0,heap;
	if (v[1]>=v[2]) //初始判断
	{
		heap = 1;
		for (int i = 0; i < 1006; i++)
		{
			if (path[i].size() != 0)
			{
				for (int j = 0; j < path[i].size() - 1; j++)
				{
					if (v[path[i][j]]<v[path[i][j+1]])//不符合初始判断
					{
						heap = 0;
					}
				}
			}
		}
	}
	else if(v[1]<=v[2])//初始判断
	{
		heap = 2;
		for (int i = 0; i < 1006; i++)
		{
			if (path[i].size() != 0)
			{
				for (int j = 0; j < path[i].size() - 1; j++)
				{
					if (v[path[i][j]] > v[path[i][j + 1]])//不符合初始判断
					{
						heap = 0;
					}
				}
			}
		}
	}
	for (int i = 0; i < 1006; i++)//输出路径
	{
		if (path[i].size()!=0)
		{
			cout << v[path[i][0]];
			for (int j = 1; j < path[i].size(); j++)
			{
				cout << " "<<v[path[i][j]];
			}
			cout << endl;
		}
	}
	if (heap==0)
	{
		cout << "Not Heap" << endl;
	}
	else
	{
		printf("%s Heap\n", heap == 1 ? "Max" : "Min");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值