1103 Integer Factorization (30分) DFS深度优先搜索 经典递归

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

 看着难,其实还好,挺经典。

柳:

#include <iostream>
#include <vector>
#include <cmath>

using namespace std;

int n, k, p, maxfacsum = -1;
vector<int> v, tempans, ans;

void init()
{
	int temp = 0, index = 0;
	while (temp <= n)
	{
		temp = pow(index, p);//这里不严格,temp可能大于n然后进入v中了,但是不会影响下面的dfs
		v.push_back(temp);
		index++;
	}
}

void dfs(int index, int tempsum, int tempk, int facsum)
{
	if (tempk == k)//一切条件都满足都成立的情况
	{
		if (tempsum == n && facsum > maxfacsum)//满足条件了,就把路径保存下来赋值给ans。
		{
			ans = tempans;
			maxfacsum = facsum;
		}
		return;
	}
	while (index >= 1)
	{
		if (tempsum + v[index] <= n)
		{
			tempans[tempk] = index;
			dfs(index, tempsum + v[index], tempk + 1, facsum + index);
		}
		if (index == 1)//这个地方超级重要,但是作用说不清楚。
		{
			return;
		}
		index--;//如果tempsum+v[index]>n,就得减小index,看加上小一点值的平方怎么样。
	}
}

int main()
{
	freopen("in.txt", "r", stdin);
	cin >> n >> k >> p;
	init();
	tempans.resize(k);
	dfs(v.size() - 1, 0, 0, 0);
	if (maxfacsum == -1)
	{
		cout << "Impossible" << endl;
	}
	else
	{
		cout << n << " = ";
		cout << ans[0] << "^" << p;
		for (int i = 1; i < ans.size(); i++)
		{
			cout << " + " << ans[i] << "^" << p;
		}
		cout << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值