A1103. Integer Factorization

1103. Integer Factorization (30)

时间限制
1200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112+ 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible

此题就是先用fac向量记录下标的p次方,再用DFS从后往前搜
有个细节要注意,fac最大下标的p次方要小于等于n,漏等于4号数据点过不去

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
vector<int> temp, ans, fac;
int n, k, p;
int max_fac = 0;

int pow(int x){
	int sum = 1;
	for(int i = 0; i < p; ++i)
		sum *= x;
	return sum;
}

void init(){
	int i = 0;
	while(pow(i) <= n)     //此处一定要加=,不然4号数据点会过不去,数据点类似 169 1 2   不加=会输出Impossible , 实际上是169 = 13^2
		fac.push_back(pow(i++));
}

void DFS(int x, int sum, int numK, int sum_fac){
	if(sum > n || numK > k || x < 1)
		return ;
	if(sum == n && numK == k && sum_fac > max_fac){
		max_fac = sum_fac;
		ans = temp;
	}
	temp.push_back(x);
	DFS(x, sum + fac[x], numK + 1, sum_fac + x); //可重选x
	temp.pop_back();
	DFS(x - 1, sum, numK, sum_fac);  //不选x
}

int main(){
	freopen("1103.txt", "r", stdin);

	scanf("%d%d%d", &n, &k, &p);
	init();
	DFS(fac.size() - 1, 0, 0, 0);
	if(ans.size() != 0){
		printf("%d = ", n);
		for(int i = 0; i < ans.size(); ++i){
			printf("%d^%d", ans[i], p);
			if(i != ans.size() - 1) printf(" + ");
		}
	}else{
		printf("Impossible");
	}

	fclose(stdin);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值