02-线性结构3 Reversing Linked List (25 分)

02-线性结构3 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K(≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

 我的代码:(数组做法)

#include <iostream>
#include <algorithm>

using namespace std;
int list[100010];
int node[100010][2];

int main()
{
	int cnm, n, k;
	cin >> cnm >> n >> k;
	int address, data, next;
	for (int i = 0; i < n; i++)
	{
		cin >> address >> data >> next;
		node[address][0] = data;
		node[address][1] = next;
	}
	int c = 0,first=cnm;
	while (first!=-1)
	{
		list[c++] = first;
		first = node[first][1];
	}
	int i = 0;
	while (i+k<=c)
	{
		reverse(list + i, list + i + k);
		i = i + k;
	}
	for ( i = 0; i < c-1; i++)
	{  //错因在这里 最后的这个i不能是for语句里定义的:for ( int i = 0; i < c-1; i++)这样是错的 for结束就释放掉了
		//因为for后面还要printf一次,那个i的值是接着for结束时i的值。
		printf("%05d %d %05d\n", list[i], node[list[i]][0], list[i + 1]);
	} //其实我知道是接着for语句结束时的i,但是就是这样细节 耽误时间 很细节
	printf("%05d %d -1\n", list[i], node[list[i]][0]);
	return 0;
	
}

链表做法: (未实现)

#include <iostream>
#include <iomanip>
#include <algorithm>
using namespace std;

#define maxsize 100001

typedef struct node
{
	int address;
	int data;
	int nextaddress;
	struct node *next;
}Node,*LinkedList;

struct arrnode
{
	int address;
	int data;
	int nextaddress;
}arrnode[maxsize];

int n,k,head_address;

void read()
{
	cin >> head_address >> n >> k;
	for (int i = 0; i < n; i++)
	{
		cin >> arrnode[i].address >> 
			arrnode[i].data >> arrnode[i].nextaddress;
	}
}

LinkedList init_linkedlist()
{
	LinkedList L = (LinkedList)malloc(sizeof(Node));
	L->next = NULL;
	
	LinkedList r = (LinkedList)malloc(sizeof(Node));
	r = L;
	
	int t = n,count=0;
	while (t--)
	{
		for (int i = 0; i < n; i++)
		{
			if ((arrnode[i].address==head_address)&&
						(head_address!=-1))
			{
				LinkedList s = (LinkedList)malloc(sizeof(Node));
				s->next = NULL;
				s->address=arrnode[i].address;
				s->data = arrnode[i].data;
				s->nextaddress = arrnode[i].nextaddress;
				r->next = s;
				r = s;
				count++;
				head_address = s->nextaddress;
				break;
			}
		}
	}
	n = count;
	return L;
}

void reverse(LinkedList head, int k)
{
	
	int count = n / k;
	while (count--)
	{
		LinkedList p1 = head->next, p2 = p1->next, tail = p1;
		while (--k)
		{
			
			LinkedList t = p2->next;
			p2->next = p1;
			p2->nextaddress = p1->address;
			p1 = p2;
			p2 = t;
		}
		head->next = p1;
		head->nextaddress = p1->address;
		tail->next = p2;
		tail->nextaddress = p2->address;
		head = tail;
		tail = p2;
	}
	
}

void print(LinkedList L)
{
	LinkedList p = L->next;
	while (p)
	{		
		cout << setfill('0') << right
			<< setw(5) << p->address << " ";
		cout << setw(1) << p->data << " ";
		if (p->nextaddress==-1)
		{
			cout << setfill(' ') <<left<< setw(5) <<p->nextaddress<< endl;
		}
		else
		{
			cout << setfill('0') << right<<setw(5) << p->nextaddress << endl;
		}
		
		p = p->next;
	}
}

int main()
{
	read();
	LinkedList L = init_linkedlist();
	//LinkedList L = (LinkedList)malloc(sizeof(Node));
	if (k!=1)
	{
		reverse(L, k);
	}

	print(L);

	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 给定一个常数 $K$ 以及一个单链表 $L$,请编写程序将 $L$ 中每 $K$ 个结点反转。例如:给定 $L$ 为 1→2→3→4→5→6,$K$ 为 3,则输出应该为 3→2→1→6→5→4;如果 $K$ 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 $K$ 个元素不反转。 输入格式 每个输入包含一个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 $N (\le 10^5)$、以及正整数 $K (\le N)$,即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。 接下来有 $N$ 行,每行格式为: Address Data Next 其中 Address 是结点地址;Data 是该结点保存的整数数据;Next 是下一结点的地址。题目保证给出的链表不为空。 输出格式 对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。 输入样例 00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 23333 2 33218 输出样例 00000 4 33218 33218 3 12309 12309 1 99999 99999 5 68237 68237 6 23333 23333 2 -1 题目析 本题需要将链表中每 $K$ 个结点反转,可以采用迭代的方法,每次找到 $K$ 个结点,将这 $K$ 个结点反转,然后将这 $K$ 个结点的前驱结点指向反转后的第一个结点,将反转后的 $K$ 个结点的最后一个结点指向下一个要反转的结点,然后继续进行下一轮反转。 需要注意的是,如果链表长度不足 $K$,则不进行反转。 代码实现
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值