02-线性结构3 Reversing Linked List(25 分)

题目来源:中国大学MOOC-陈越、何钦铭-数据结构-2018春
作者: 陈越
单位: 浙江大学

问题描述:
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

解答:我记得PAT做过类似的题,数据结构采用结构体数组来存放每一个结点的信息,把数组空间开到题目要求的最大,其中结构体中的order变量用于遍历时给输入的每个节点一个次序值(空的节点可以给一个INF极大值以保证在sort排序时这些空节点排在最后,翻转的时候就不用管这些节点),在遍历结束的同时也帮我们筛掉了有可能不与其他节点相连的孤立节点。然后用sort根据order的值进行排序。接下来就可以进行翻转操作了,把链表长度(排除掉孤立节点)/ 翻转K值 得出总共需要翻转次数+1,把整个链表分成若干以K为长度的小区间,当不是最后一次翻转时,从每个小区间后往前直接输出结果,当是最后一次翻转时,我们需要判断输出最后一个‘-1’

#include <iostream>
#include <algorithm>
using namespace std;
struct node
{
    int address;
    int date;
    int next;
    int order;
    node()
    {
        order=10000000000;
    }
};
const int maxn=100000;
node List[maxn];
bool cmp(node a,node b)
{
    return a.order<b.order;
}
int main()
{
    int startpos,nodeNum,K;
    cin>>startpos>>nodeNum>>K;
    int startNode=startpos;
    for(int i=0;i<nodeNum;i++)
    {
        int address;
        cin>>address;
        cin>>List[address].date;
        cin>>List[address].next;
        List[address].address=address;
    }
    int order=1;
    while(startNode!=-1)
    {
        List[startNode].order=order;
        order++;
        startNode=List[startNode].next;
    }
    order--;
    sort(List,List+maxn,cmp);
    int start;
    for(int j=0;j<order/K;j++)
    {
        start=j*K;
        int i;
        for(i=start+K-1;i>start;i--)
        {
            printf("%05d %d %05d\n",List[i].address,List[i].date,List[i-1].address);
        }
        if(j!=order/K-1)
        {
            printf("%05d %d %05d\n",List[i].address,List[i].date,List[i+K*2-1].address);
        }
        else
        {
            if(order%K==0)
                printf("%05d %d -1\n",List[i].address,List[i].date);
            else
            {
                printf("%05d %d %05d\n",List[i].address,List[i].date,List[i+K].address);
                for(int last=(j+1)*K;last<order-1;last++)
                {
                    printf("%05d %d %05d\n",List[last].address,List[last].date,List[last].next);
                }
                printf("%05d %d -1\n",List[order-1].address,List[order-1].date);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值