【PAT甲级】1099 Build A Binary Search Tree

 

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

这道题的大概意思就是说给定你了一个二叉树的结构和待填入的数据,让你构建一棵二叉搜索树,因为给定了结构和数据,所以二叉搜索树唯一,最后对构建好的二叉搜索树进行层序遍历。

由于这是一棵二叉搜索树,所以对这棵树进行中序遍历的时候我们可以得到从小到大排序的数据

解题思路

1. 我们使用数组来表示这棵树

2. 我们对构建好的树使用中序遍历将结点排序

3. 接收数据,然后对数据从小到大排序

4. 将结点和数据一一对应赋值

5. 层序遍历输出这棵BST

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <vector>
#include <queue>

using namespace std;

#define MAXSIZE 150

//BST结点结构体
struct  node {
	int data;
	int lchild;
	int rchild;
}nod[MAXSIZE];

//从小到大排序,如果a<b输出1,否则输出0 
int cmp(int a, int b){
	if(a <= b) return 1;	//不需要交换顺序 
	else return 0;			//需要交换顺序 
}

vector<int> in;	//用来装中序遍历顺序的BST结点

//中序遍历结点,传递的参数是结点数组的指针 
void inorder(int idx){
	if(idx == -1) return;
	inorder(nod[idx].lchild);
	in.push_back(idx);
	inorder(nod[idx].rchild);
}

//层序遍历,num记录结点个数,root是树根的指针 
int BFS(int num, int root){
	queue<int> q;
	q.push(root);
	int tmp;
	int cnt = 0;
	while(!q.empty()){
		tmp = q.front();
		printf("%d", nod[tmp].data);
		cnt++;
		if(cnt<num) printf(" ");
		q.pop();
		if(nod[tmp].lchild!=-1) q.push(nod[tmp].lchild);
		if(nod[tmp].rchild!=-1) q.push(nod[tmp].rchild); 
	}
}
 
 
int main(){
	int num;
	scanf("%d", &num);
	int a, b;	//记录左右孩子指针
	for(int i=0; i<num; i++){
		scanf("%d %d", &a, &b);
		nod[i].lchild = a;
		nod[i].rchild = b;
	}
	//将结点进行排序
	inorder(0); 
	//输入data并排序
	int data[MAXSIZE];
	for(int i=0; i<num; i++){
		scanf("%d", &data[i]);
	} 
	sort(data, data+num, cmp);
	//赋值
	for(int i=0; i<num; i++){
		nod[in[i]].data = data[i];
	} 
	//打印
	BFS(num, 0); 
	return 0;
}


 

【Solution】 To convert a binary search tree into a sorted circular doubly linked list, we can use the following steps: 1. Inorder traversal of the binary search tree to get the elements in sorted order. 2. Create a doubly linked list and add the elements from the inorder traversal to it. 3. Make the list circular by connecting the head and tail nodes. 4. Return the head node of the circular doubly linked list. Here's the Python code for the solution: ``` class Node: def __init__(self, val): self.val = val self.prev = None self.next = None def tree_to_doubly_list(root): if not root: return None stack = [] cur = root head = None prev = None while cur or stack: while cur: stack.append(cur) cur = cur.left cur = stack.pop() if not head: head = cur if prev: prev.right = cur cur.left = prev prev = cur cur = cur.right head.left = prev prev.right = head return head ``` To verify the accuracy of the code, we can use the following test cases: ``` # Test case 1 # Input: [4,2,5,1,3] # Output: # Binary search tree: # 4 # / \ # 2 5 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 <-> 4 <-> 5 # Doubly linked list in reverse order: 5 <-> 4 <-> 3 <-> 2 <-> 1 root = Node(4) root.left = Node(2) root.right = Node(5) root.left.left = Node(1) root.left.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) # Test case 2 # Input: [2,1,3] # Output: # Binary search tree: # 2 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 # Doubly linked list in reverse order: 3 <-> 2 <-> 1 root = Node(2) root.left = Node(1) root.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) ``` The output of the test cases should match the expected output as commented in the code.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值