1037 Magic Coupon

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

解题思路:

题目大意是说,给你两个集合coupon和product,对于coupon中的每一个元素,你需要在product集合中找到一个元素与之相乘,使得最后得到的结果最大。注意,coupon和product的元素个数不一定相等。

大题的思路就是,我们先将两个集合都按照从小到大的顺序排序,这样就可以将集合分为小于等于零的部分和大于零的部分。对于小于零的部分,我们直接用两个集合中都为负且当前可选的绝对值最大的数进行相乘;对于大于零的部分还是选择当前可选的值最大的两个数相乘,零可以不用计算,因为零乘以任何数都是零。

#include <stdio.h>
#include <algorithm>
using namespace std;

typedef long long ll;

const int maxn = 100010;
int coupon[maxn];
int product[maxn];

int main(){
	int n;
	scanf("%d", &n);
	for(int i=0; i<n; i++){
		scanf("%d", &coupon[i]);
	}
	int m;
	scanf("%d", &m);
	for(int i=0; i<m; i++){
		scanf("%d", &product[i]);
	}
	//从小到大进行排序 
	sort(coupon, coupon+n);
	sort(product, product+m);
	
	ll ans = 0;
	int i=0;
	while(i<n && i<m && coupon[i]<0 && product[i]<0){
		ans += coupon[i]*product[i];
		i++;
	}
	int j=m-1;
	i=n-1;
	while(i>=0 && j>=0 && coupon[i]>0 && product[j]>0){
		ans += coupon[i]*product[j];
		i--; j--;
	}
	printf("%lld\n", ans);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值