1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

解题思路:

这道题的意思是给了你一个大小固定的栈,然后入栈顺序是从1到N,再给定你几组出栈顺序,让你判断指定的出栈顺序是否合法,合法则输出"YES",不合法则输出"NO"。

解题的思路也很简单,可以直接使用STL里面的栈,读入给定的出栈序列后逐个进行判断,我们使用一个标志flag表示该序列是否合法,如果出循环后flag==0则不合法,flag==1则合法,每次判断前都先按照顺序进行入栈,然后判断栈顶元素和出栈序列当前元素是否相同,相同则一直出栈,知道他们不相同为止。

#include <iostream>
#include <stdio.h>
#include <stack>
using namespace std;

const int maxn = 1010;
int arr[maxn];		//保存给定的出栈序列 

int main(){
	int m, n, k;
	scanf("%d %d %d", &m, &n, &k);
	for(int i=0; i<k; i++){		//循环k次 
		stack<int> s;
		for(int j=1; j<=n; j++){	//记录出栈序列 
			scanf("%d", &arr[j]);
		}
		int flag = 1;
		int current = 1;
		for(int j=1; j<=n; j++){
			s.push(j);		//按照顺序入栈
			if(s.size() > m){		//如果栈内元素容量超过m则不符合条件 
				flag = 0;
				break;
			} 
			// 只要栈顶元素和出栈序列吻合就出栈 
			while(s.empty()!= true && s.top()==arr[current]){
				s.pop();
				current++;
			}
		}
		if(s.empty()==true && flag==1){
			printf("YES\n");
		} else {
			printf("NO\n");
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值